SkIndigo 3.8.6.1

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 8:01 am

lape wrote:Component instancing does not work.
Hi lape,
In what way does it not work?

Do you only see one component instance? Does it give an error message?

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: SkIndigo 3.6.8.1

Post by lape » Wed Jul 30, 2014 8:10 am

I don't get an error, I only the see the component, the dummies I used for instancing just can't be seen.
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 8:11 am

lape wrote:Component instancing does not work.

I know, I should not install a beta when I have to finish a project, but now I reinstalled 3.6.28.3 and get this:

SkIndigo version: 3.6.28.3
SketchUp version: 14.1.1282
Ruby platform: i386-mingw32
Error during processing: BlendMaterialUndefined
C:/Users/Knopp/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb:8533:in `write_mat'
C:/Users/Knopp/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb:8282:in `export_material'
C:/Users/Knopp/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb:968:in `block in export'
C:/Users/Knopp/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb:967:in `each'
C:/Users/Knopp/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb:967:in `export'
C:/Users/Knopp/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb:11606:in `block in <top (required)>'
-e:1:in `call'

any help? :?
Regarding your error, looks like a blend material has an invalid child (material a or material b).

User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 8:12 am

lape wrote:I don't get an error, I only the see the component, the dummies I used for instancing just can't be seen.
Are you using the _dummy technique?

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: SkIndigo 3.6.8.1

Post by lape » Wed Jul 30, 2014 8:15 am

yes, _dummy!

I did not use a blend material, just used a hdri for environment map + add sun from sketchup. When I try tu use light layers, the error occurs.
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 8:17 am

lape wrote:yes, _dummy!
Ok. The '_dummy' bit is case sensitive now, so it must be lower case. If you want to send me your scene I can try it out here.

User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 8:29 am

Uploaded new version, uses a different mesh cache directory, which should help prevent bad interactions with previously cached meshes from the 3.6 skindigo series.

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: SkIndigo 3.6.8.1

Post by lape » Wed Jul 30, 2014 8:30 am

The worst thing is that i cannot get my environment map work!
Now I am back on 3.8., and this is what happens, see attached screenshots.
Attachments
environment.jpg
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 8:45 am

lape wrote:The worst thing is that i cannot get my environment map work!
Now I am back on 3.8., and this is what happens, see attached screenshots.
Can you send me the .skp file?

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: SkIndigo 3.6.8.1

Post by lape » Wed Jul 30, 2014 8:57 am

environment test.zip
(20.3 KiB) Downloaded 87 times
here it is...
24 hours isn't enough
http://www.werkraum3d.com

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: SkIndigo 3.6.8.1

Post by lape » Wed Jul 30, 2014 9:38 am

...about the instancing problem:

It only works, when the component doesn't contain other components. In my case, it is a hedge, and there are different components for leaves, branches etc. When I explode these components, and only have one major component, the dummies will work. Unfortunately this blows up my filesize.... :cry:
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 9:39 am

lape wrote:...about the instancing problem:

It only works, when the component doesn't contain other components. In my case, it is a hedge, and there are different components for leaves, branches etc. When I explode these components, and only have one major component, the dummies will work. Unfortunately this blows up my filesize.... :cry:
Can you send me the scene via dropbox pls?

User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 9:54 am

lape wrote:The worst thing is that i cannot get my environment map work!
Now I am back on 3.8., and this is what happens, see attached screenshots.
This seems to be an issue with sun + env map with bidir enabled. Just avoid that combination for now.

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: SkIndigo 3.6.8.1

Post by lape » Wed Jul 30, 2014 10:16 am

OnoSendai wrote:
lape wrote:The worst thing is that i cannot get my environment map work!
Now I am back on 3.8., and this is what happens, see attached screenshots.
This seems to be an issue with sun + env map with bidir enabled. Just avoid that combination for now.
No, it also doesn't work using path tracing, can't get the sun layer working while environment map is in use! And if you use camera instead of reinhard, everything turns black...

Back to 3.6 ???
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6216
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: SkIndigo 3.6.8.1

Post by OnoSendai » Wed Jul 30, 2014 10:32 am

Updated build, fixed the hedge instancing.

Post Reply
148 posts

Who is online

Users browsing this forum: Semrush [Bot] and 4 guests