Page 1 of 1

SkIndigo (beta)

Posted: Tue May 13, 2014 5:39 am
by OnoSendai

This is a bugfix release. See changelog below for details.

This is a beta release - please test. Please install Indigo 3.6.26 or newer before this version. Get it from here: ... =1&t=12701

To Install:
On windows, you can use the Windows installer.
1) Download RBZ file from link below
2) In SketchUp, go to Window->Preferences->Extensions
3) Uncheck the SkIndigo checkbox, press OK, restart SketchUp
4) In SketchUp, go to Window->Preferences->Extensions->Install Extension
5) Select the RBZ file you downloaded
6) Check the SkIndigo checkbox again.
7) Restart Sketchup again.

NOTE: this elaborate process is to make sure the asset files get updated properly, which doesn't work if the extension is enabled.


Fixed problem exporting scenes with Unicode characters in material names. Would display an error dialog in Indigo like
"Scene parsing error: Error while binding material 'cópi' to geometry 'leaf1': No such material defined 'cópi'"

RBZ file: (all platforms) ... 6.28.1.rbz

Windows Installer: ... taller.exe

Let us know if there are any problems with this beta release!

Re: SkIndigo (beta)

Posted: Tue May 13, 2014 6:42 am
by Oscar J
Indigo 3.8 is working just great for me. Will there be any exporters featuring the new features anytime soon?

Re: SkIndigo (beta)

Posted: Fri May 16, 2014 11:05 am
by Enrico
Hi Ono! The new Skindigo version is so faster but there was a problem. If I try to open a file with the 2014 version of Sketchup, the program doesn't load Skindigo's toolbar. To avoid this problem you need to open Sketchup 2014 and start the desired file from the Sketchup Toolbar "File-->Open". If you follow this procedure the problem seems to be solved.

Re: SkIndigo (beta)

Posted: Mon May 26, 2014 10:22 pm
by Linde
Hello there,
I hope this is the right place to write this: I have the same problem as Enrico, and it has been going on with the previous version of Skindigo too... Opening the file from the Sketchup menu doesn't completely solve this, because this way I lose all my saved POVs and all the custom settings in the indigo menu. Also, I'm working on a very large model right now, so importing it to a new file 90% of the times makes Sketchup crash.
This actually doesn't make it impossible to work, but it doubles the time I have to spend to set everything again every time I have to make a change to the model (which happens almost daily).
I work with SketchUp 2014 (v. 14.0.4900) on Windows 7, and I use SkIndigo Released 12 May 2014 with a commercial Indigo RT v3.6.26, Windows 64-bit build.
Thank you very much :)

Re: SkIndigo (beta)

Posted: Tue May 27, 2014 10:25 pm
by OnoSendai
This is a SketchUp bug that should be fixed in their SketchUp 2014 maintenance 1 (M1) release.

Edit: Here's the bug they fixed:

"Fixed an issue where launching SketchUp by double­clicking a skp file on another drive 
would corrupt $LOAD_PATH and render the Standard Library inaccessible.  This bug 
caused many people to run into plugin loading problems if they were opening files located 
on drives other than their “C:” drive."

Edit 2: Just tried the Maintenance 1 release candidate, it does indeed solve this problem.

Re: SkIndigo (beta)

Posted: Tue May 27, 2014 10:27 pm
by Linde
allright :) thank you very much!!!

Re: SkIndigo (beta)

Posted: Wed May 28, 2014 12:11 am
by Enrico
Thank you Ono!

Re: SkIndigo (beta)

Posted: Thu May 29, 2014 5:59 am
by Enrico
The problem persist!! I wait the next update :(