problem with environment map and exit portals

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

problem with environment map and exit portals

Post by lape » Fri Jun 14, 2013 4:11 am

I just tried to render a scene using exit portals. I also used an environment map. Without exit portals everything is fine, and my scene renders like it should. But when I use exit portals, the environment map turns black. I already read some posts from Pibuz who seemed to have the same problem with Skindigo http://www.indigorenderer.com/forum/vie ... 0&start=75) but whatever values I use for sun, environment map and emission: no chance :(

I also tried to export the scene and change the settings for the background settings via the property editor, but whenver I try to change anything, Indigo crashes.

What seems to work: Export the scene without environment map, and then use the property editor to load a new exr. If I do this, I can change all settings for the exr, but now I have no button to add the sun???

Any help?
Attachments
settings.jpg
no exitportal01.jpg
with exitportal02.jpg
24 hours isn't enough
http://www.werkraum3d.com

User avatar
Whaat
Developer
Posts: 1824
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: problem with environment map and exit portals

Post by Whaat » Fri Jun 14, 2013 6:07 am

Try changing your rendering method and see if that makes a difference. If try using a Bidirectional method if you weren't before and vice versa.

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: problem with environment map and exit portals

Post by lape » Fri Jun 14, 2013 6:21 am

I already tried every rendering method available. EXR always stays black when exit portals are active.... Im getting frustrated :cry:

It seems to be a problem with the emission values?
24 hours isn't enough
http://www.werkraum3d.com

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am

Re: problem with environment map and exit portals

Post by dag » Fri Jun 14, 2013 7:25 am

Flip normal on the exit portal plane.

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: problem with environment map and exit portals

Post by lape » Fri Jun 14, 2013 8:25 am

there is no problem with the normals, this was the first thing I looked at.
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: problem with environment map and exit portals

Post by OnoSendai » Fri Jun 14, 2013 10:07 am

Hi lape,
I'll have a look at this soon (tmrw hopefully) and try and fix it.

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: problem with environment map and exit portals

Post by lape » Fri Jun 14, 2013 10:19 am

that would be great! :D
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: problem with environment map and exit portals

Post by OnoSendai » Fri Jun 14, 2013 10:34 am

Hi Lape,
Is the problem occurring when you tick the 'Add Sun' checkbox in the SketchUp environment map settings?

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: problem with environment map and exit portals

Post by lape » Sat Jun 15, 2013 7:36 pm

OnoSendai wrote:Hi Lape,
Is the problem occurring when you tick the 'Add Sun' checkbox in the SketchUp environment map settings?
No, the problem also occurs if I only use the environment map for lighting. And it doesn't matter if I use "blackbody" or "uniform" for the emission. As soon as exit portals are active, environment map renders black. I already tried different exr files, but the result stays the same :cry:
Attachments
only environment map.jpg
settings2.jpg
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: problem with environment map and exit portals

Post by OnoSendai » Sun Jun 16, 2013 11:23 am

I think I have figured out the problem and fixed it. Fix will be in the next release (3.6.16)

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: problem with environment map and exit portals

Post by lape » Mon Jun 17, 2013 7:13 am

OnoSendai wrote:I think I have figured out the problem and fixed it. Fix will be in the next release (3.6.16)
Thank you! :mrgreen:
24 hours isn't enough
http://www.werkraum3d.com

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: problem with environment map and exit portals

Post by OnoSendai » Tue Jun 18, 2013 4:54 am

This should be fixed in 3.6.16: http://www.indigorenderer.com/forum/vie ... =1&t=12429
What I have done is make the exit portals use the emission scale from the background material.
So the background should now be the same brightness with and without exit portals.

User avatar
lape
Posts: 241
Joined: Wed Feb 13, 2013 9:09 am
Location: Germany
Contact:

Re: problem with environment map and exit portals

Post by lape » Tue Jul 02, 2013 7:54 am

OnoSendai wrote:This should be fixed in 3.6.16: http://www.indigorenderer.com/forum/vie ... =1&t=12429
What I have done is make the exit portals use the emission scale from the background material.
So the background should now be the same brightness with and without exit portals.
Sorry, but I don't get it...I still get a black environment map. What am I doing wrong? This is driving me mad :?
I attached my simple Sketchup test model with exit portal and exr, perhaps somebody can try it and post a result with settings?
Attachments
test exit portal.jpg
test ep.zip
(2.2 MiB) Downloaded 168 times
24 hours isn't enough
http://www.werkraum3d.com

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: problem with environment map and exit portals

Post by CTZn » Tue Jul 02, 2013 11:19 am

The problem might lie into the scene since changing the map did not help.

Try scaling the faulty portal up and down, to test a full intersection with the walls and also no intersection.

Redo the portal geometry ?

If activating the portals into the scene means unhiding them, make sure that there is no duplicate geometry around.
obsolete asset

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am

Re: problem with environment map and exit portals

Post by dag » Tue Jul 02, 2013 4:35 pm

You need exit portals in both windows. Light only goes through exit portals if one is in the scene.

Post Reply
33 posts

Who is online

Users browsing this forum: No registered users and 10 guests