Exit Portal with no shadow

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
Post Reply
6 posts • Page 1 of 1
draconic
Posts: 12
Joined: Fri Oct 24, 2008 8:03 am

Exit Portal with no shadow

Post by draconic » Wed Jun 06, 2012 2:44 am

Hello everyone I have questions about Exit Portals.
First of all, I'm using latest Indigo and Skindigo versions. The Scene setup is; camera advantix 100, Bidir PT, no glass, it's just a simple test scene. I followed the Exit Portal tutorial step by step.
In first picture I used sun&sky environment, second one is done with Exit Portal.
EP was too dark so I used EV adjust to lighten it (third one).
Here's my question: where have my shadows gone?
Attachments
Without EP.jpg
With EP.jpg
With EP-EV5.jpg

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Exit Portal with no shadow

Post by CTZn » Wed Jun 06, 2012 3:53 am

This is a known limitation of Path Tracing with Exit Portals, they don't cope together. Path Tracing is forced on by Indigo whenever GPU acceleration is used.
obsolete asset

draconic
Posts: 12
Joined: Fri Oct 24, 2008 8:03 am

Re: Exit Portal with no shadow

Post by draconic » Wed Jun 06, 2012 5:17 am

I went back to older version 3.0 and Exit Portal is working fine.
But only with Bidir PT and Bidir MLT. GPU acceleration is not supported as you mentioned.
Is this a kind of bug between 2 different versions?
Attachments
EP.jpg

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Exit Portal with no shadow

Post by CTZn » Wed Jun 06, 2012 7:31 am

I think that the main difference is that the newest SkIndigo has GPU acceleration on by default in the Advanced Render Settings. In this case, the GPU will use single path tracing (bad with EP's by nature), disregarding the Tracing Method setting !

The render from 3.0 uses bidir as default while the latest version is forcing GPU (path tracing) I think.
obsolete asset

draconic
Posts: 12
Joined: Fri Oct 24, 2008 8:03 am

Re: Exit Portal with no shadow

Post by draconic » Wed Jun 06, 2012 7:58 am

Wow you're right. GPU acceleration was on by default. I switched it off and now it's perfect.
Thanks for the solution. Case is closed I think 8)

User avatar
Headroom
Indigo 100
Posts: 991
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Exit Portal with no shadow

Post by Headroom » Wed Jun 06, 2012 1:13 pm

I say this one more time :wink:

For interior scenes that are lit by exterior light sources, e.g.. Sun/Sky, path tracing is usually not the best render method. It may work out favorably in these simple test scenes, but once you add "stuff" with more complex materials simple path tracing quickly runs out of breath.

Thus, for realistic scenes (within the above described constraints) it's really not so much of a limitation.

Post Reply
6 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest