Unwanted mesh smoothing (subdivision?)

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Fri Nov 11, 2011 2:47 am

kwistenbiebel wrote:
Whaat wrote:[
hey Chris,

this should be fixed in the just released version 3.2.0. Please let me know :)
Hi Dale,

Mmm, I experience the same issue in the new version.
Hi,

Please send me a scene showing the bug for testing. Thanks!

Dale

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Fri Nov 11, 2011 2:56 am

I am :)

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Mon Nov 14, 2011 2:20 pm

Whaat wrote:
kwistenbiebel wrote:
Whaat wrote:[
hey Chris,

this should be fixed in the just released version 3.2.0. Please let me know :)
Hi Dale,

Mmm, I experience the same issue in the new version.
Hi,

Please send me a scene showing the bug for testing. Thanks!

Dale
It's a 127 Mb file Sketchup file .. I'll zip it and use Yousendit to get it to you.

Thank you,
Chris

User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Mon Nov 14, 2011 5:20 pm

Can you just isolate the geometry in question in a separate (small) SKP file? I don't need everything, just the faces that are causing the problems.

Thanks!

User avatar
cotty
Posts: 314
Joined: Tue Aug 03, 2010 7:59 am
Location: Germany
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by cotty » Thu Nov 17, 2011 3:00 am

Perhaps this error have to do with this topic?
http://www.indigorenderer.com/forum/vie ... =5&t=11271
An example model is attached there...
Cotty

(I am using Indigo 3.2.0 and SkIndigo 3.2.1 with Sketchup 8 )

EDIT: I have installed Indigo 3.2.2 and get the same error...
little gallery... http://unverzagt.biz/cottysgallery/

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Thu Nov 17, 2011 3:39 pm

cotty wrote:Perhaps this error have to do with this topic?
http://www.indigorenderer.com/forum/vie ... =5&t=11271
An example model is attached there...
Cotty

(I am using Indigo 3.2.0 and SkIndigo 3.2.1 with Sketchup 8 )

EDIT: I have installed Indigo 3.2.2 and get the same error...
Could well be ....it sure feels liek 'depreciated' geometry.

@Whaat:
I isolated some of the geometry, copy pasted it in a new file and it renders perfectly.
When I copy paste it back into the (130 Mb) Sketchup file... it goes wrong again.

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Thu Nov 17, 2011 5:38 pm

Another observation:
On one computer I have the artefacts and when I open the same file on another PC ...not.
As I need to swap a lot from one PC to another, it is unpredictable whether it will run or not.
Can it have anything to do with texture caching?
That was my first suspicion when swapping computers, however, when I just use a plain color as a material it happens as well.....

User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Sun Nov 20, 2011 11:45 am

kwistenbiebel wrote:Another observation:
On one computer I have the artefacts and when I open the same file on another PC ...not.
As I need to swap a lot from one PC to another, it is unpredictable whether it will run or not.
Can it have anything to do with texture caching?
That was my first suspicion when swapping computers, however, when I just use a plain color as a material it happens as well.....
Please verify that you are using the exact same SkIndigo version on the computers.

Also, if there is any way you can share the 130MB file, I would love to take a look at it. :)

User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Sun Nov 20, 2011 11:47 am

cotty wrote:Perhaps this error have to do with this topic?
http://www.indigorenderer.com/forum/vie ... =5&t=11271
An example model is attached there...
Cotty

(I am using Indigo 3.2.0 and SkIndigo 3.2.1 with Sketchup 8 )

EDIT: I have installed Indigo 3.2.2 and get the same error...
Hey cotty,

I have been really busy that last few days but I plan on taking a look at your issue next week for sure. Try running the 'fix problems' feature in SketchUp to make sure that problem isn't due to bad geometry.

User avatar
cotty
Posts: 314
Joined: Tue Aug 03, 2010 7:59 am
Location: Germany
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by cotty » Mon Nov 21, 2011 6:26 pm

Whaat wrote:Try running the 'fix problems' feature in SketchUp to make sure that problem isn't due to bad geometry.
I have tried but it didn't change the behaviour...
little gallery... http://unverzagt.biz/cottysgallery/

User avatar
cotty
Posts: 314
Joined: Tue Aug 03, 2010 7:59 am
Location: Germany
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by cotty » Fri Nov 25, 2011 2:22 am

Here is another example with relatively simple geometry (the stem should be perfect smooth,...). I am sure that I never had such problems with older versions (of indigo?)...
What properties of the geometry (subdivision,...) can I check to find the reason for this behaviour?
Attachments
forum_tree_error.jpg
Example render
little gallery... http://unverzagt.biz/cottysgallery/

User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Fri Nov 25, 2011 2:46 am

cotty wrote:Here is another example with relatively simple geometry (the stem should be perfect smooth,...). I am sure that I never had such problems with older versions (of indigo?)...
What properties of the geometry (subdivision,...) can I check to find the reason for this behaviour?
are you using world the scale parameter a very low value?

User avatar
cotty
Posts: 314
Joined: Tue Aug 03, 2010 7:59 am
Location: Germany
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by cotty » Fri Nov 25, 2011 2:56 am

Whaat wrote:are you using world the scale parameter a very low value?
Where do I find this parameter? The stem has a diameter of about 18 mm.
Here are two other renders with the choosen subdivision parameters and the model...
Attachments
tree.zip
Model
(6.69 MiB) Downloaded 67 times
forum_tree_error2.jpg
2nd example render
little gallery... http://unverzagt.biz/cottysgallery/

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Unwanted mesh smoothing (subdivision?)

Post by CTZn » Fri Nov 25, 2011 3:03 am

Cotty, set all edges with smooth normals. Hard edges will always detach when using Subdividion smoothing (though you may not always notice).
obsolete asset

User avatar
cotty
Posts: 314
Joined: Tue Aug 03, 2010 7:59 am
Location: Germany
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by cotty » Fri Nov 25, 2011 4:10 am

CTZn wrote:Cotty, set all edges with smooth normals...
How is this done? Soften edges dialog does not help, as can bee seen in the attached render.Does this workflow changed during the last updates (SkIndigo oder Indigo) because I never noticed this before?
Attachments
forum_tree_error3.jpg
little gallery... http://unverzagt.biz/cottysgallery/

Post Reply
33 posts

Who is online

Users browsing this forum: No registered users and 3 guests