Unwanted mesh smoothing (subdivision?)

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Wed Oct 12, 2011 7:09 pm

Hi Whaat,

Something funny is showing up in my renders.
Single surfaces seem to be smoothed , as if the 'soften edges' command is activated....while it is not.
It happens on all files in the later versions.
Files that did'nt have it in older Indigo versions now suffer from it.
Especially when using cut out components, it shows significantly

see images
Attachments
mesh-smoothing.jpg
mesh-smoothing-2.jpg

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Unwanted mesh smoothing (subdivision?)

Post by Pibuz » Thu Oct 13, 2011 5:55 am

Hi Kwisten, sorry to write no useful answers..
Just to report that somethimes this happens to me too. Sometimes, the solution (workaround) is to explode the object and then re-unite it. But it doesn't work all the times...

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Thu Oct 13, 2011 1:25 pm

Thank you Pibuz .How have you been ? :)
That comment does help to see that is an issue that can be adressed.
I tried exploding the mesh , and in my case it didn't help.

Perhaps Dale can shine his light on this ...

User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Fri Oct 14, 2011 4:31 am

kwistenbiebel wrote:Thank you Pibuz .How have you been ? :)
That comment does help to see that is an issue that can be adressed.
I tried exploding the mesh , and in my case it didn't help.

Perhaps Dale can shine his light on this ...
Is this a problem only with SkIndigo 3.0.15?

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Unwanted mesh smoothing (subdivision?)

Post by Pibuz » Fri Oct 14, 2011 4:52 am

Yes, never spotted before.

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Fri Oct 14, 2011 3:31 pm

Pibuz wrote:Yes, never spotted before.
Sorry to correct you Pibuz :).
It also happens in Skindigo 3.0.14.
(I needed to restore to that version because of the other issue I experienced with 'Can't find Default material'.)

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Unwanted mesh smoothing (subdivision?)

Post by Pibuz » Fri Oct 14, 2011 7:31 pm

Oh, it can easily be true: I used 3.0.14 for a very short time.

User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Sat Oct 15, 2011 4:06 am

Hi beibel,

Are you sure it happens with 3.0.14? Have you tried rendering the same scene using an older version of Indigo? I wonder if it is an Indigo bug and not a SkIndigo bug.

I now recall that I have noticed this issue a couple of times in my own renders. I fixed the issue by exploding the group or component. However, I was not yet able to determine if the issue was related to SkIndigo or Indigo. Definitely further investigation is required on my part.

Thanks for posting this.

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Sat Oct 15, 2011 4:32 am

Hi Dale,
Thank you for the reply.
I am back in the office on Tuesday and will check the installed version again.
I recall swapping between 3.0.15 , 3.0.14 and 3.0.12. in attempts to solve other things.
Your comment makes me want to check again which version I am currently running.
I'll get back to you on it to make sure you get the right feedback from me.

Cheers,
Chris

User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Tue Oct 18, 2011 6:45 am

kwistenbiebel wrote:Hi Dale,
Thank you for the reply.
I am back in the office on Tuesday and will check the installed version again.
I recall swapping between 3.0.15 , 3.0.14 and 3.0.12. in attempts to solve other things.
Your comment makes me want to check again which version I am currently running.
I'll get back to you on it to make sure you get the right feedback from me.

Cheers,
Chris
I am quite certain that this problem is in 3.0.15 only.

I believe I have resolved the issue in the next version.

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Tue Oct 18, 2011 3:06 pm

Hi Whaat,
I checked things and I am currently running Skindigo 3.0.12 and Indigo 3.0.12...

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Wed Nov 02, 2011 8:14 pm

Hi Dale,

I can confirm that this issue also happens when using Skindigo 3.0.14 together with latest Indigo.
Is there a time frame on an updated Skindigo?

This issue gives me a lot of extra Photoshop work correcting strange artefacts all over the rendered output.
And it looks less good as an original render.

Hopefully fixed soon .....

Cheers,
Chris

User avatar
Whaat
Developer
Posts: 1827
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Unwanted mesh smoothing (subdivision?)

Post by Whaat » Thu Nov 03, 2011 5:16 pm

kwistenbiebel wrote:Hi Dale,

I can confirm that this issue also happens when using Skindigo 3.0.14 together with latest Indigo.
Is there a time frame on an updated Skindigo?

This issue gives me a lot of extra Photoshop work correcting strange artefacts all over the rendered output.
And it looks less good as an original render.

Hopefully fixed soon .....

Cheers,
Chris
hey Chris,

this should be fixed in the just released version 3.2.0. Please let me know :)

User avatar
kwistenbiebel
Posts: 496
Joined: Sat Jan 27, 2007 12:31 am

Re: Unwanted mesh smoothing (subdivision?)

Post by kwistenbiebel » Thu Nov 10, 2011 3:57 pm

Whaat wrote:[
hey Chris,

this should be fixed in the just released version 3.2.0. Please let me know :)
Hi Dale,

Mmm, I experience the same issue in the new version.

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Unwanted mesh smoothing (subdivision?)

Post by Pibuz » Thu Nov 10, 2011 9:47 pm

Are you testing with 3.2.1 kwisten? just to make sure..

Post Reply
33 posts

Who is online

Users browsing this forum: No registered users and 4 guests