Problem with windows...

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
Post Reply
7 posts • Page 1 of 1
BurnGamer
Posts: 5
Joined: Mon Feb 07, 2011 2:05 pm

Problem with windows...

Post by BurnGamer » Mon Feb 07, 2011 2:28 pm

Hi everyone,

This is my first post on these forums and I'm kinda new to Indigo and SkIndigo. I'm currently experimenting with the renderer and so far I'm doing quite fine, but right now, I'm having trouble with windows.

I downloaded a material in SketchUp called Ghost Glass, which simulates a clear glass panel. So I applicated this material on my model to simulate windows.

The problem is that when I render a specific scene (see image), I can see through the glass but the sun shine doesn't enter the room, so the room is very dark.

I tried to set the opacity of the window to 0 in SketchUp, but it didn't work. So I'm wondering what I'm doing wrong.

I searched for similar topics and some people talked about the IOR, but I don't know where to set this variable.

I would like to know what to do to let the sun shine through the windows, and please be specific.

Thanks
Attachments
Scene with windows.jpg

User avatar
Headroom
Indigo 100
Posts: 972
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Problem with windows...

Post by Headroom » Tue Feb 08, 2011 12:50 am

The newest Indigo beta release 2.6.1 have built-in algorithms for Architectural Glass Acceleration that help particularly with such scenes as yours. In that case I believe you would model the glass as a thin sheet with volume. Just make sure to use the equivalent exporter to use with that Indigo version.

Also, and I am not exactly sure here either, the Ghost glass would have to be not be applied to a glass volume but to a single polygon with the surface normal pointing inwards.

Furthermore you cannot edit or change parameters for materials that you've dowloaded from the Material Database directly in your exporter e.g. Skindigo . You would have to open the Material that you've downloaded with the Indigo Material Editor in order to do that. If you want more control through your exporter you can analyze the material with the Material editor and then recreate them in Skindigo.

User avatar
Reinuvader
Posts: 34
Joined: Tue Apr 13, 2010 8:20 am
Location: Estonia
Contact:

Re: Problem with windows...

Post by Reinuvader » Tue Feb 08, 2011 2:38 am

Which tracing method you use? In rendering settings, under Advanced tab try Bidirectional MLT. But I agree, that this is problem that needs to be solved. I believe you are doing nothing wrong. Its just those tracing methods work differently, but I can't explain how they differ from each other, because I don't understand it myself.

User avatar
Bosseye
Posts: 302
Joined: Fri Jan 01, 2010 10:52 pm
Location: Bristol, UK

Re: Problem with windows...

Post by Bosseye » Tue Feb 08, 2011 4:22 am

Hmmm, interesting. Just tried to recreate your scene quickly and got this - I assume you're looking to have the sunlight slanting through the windows in 'bars' a bit like the image below? This model uses ghost glass in all the wall openings and the sun still seems to come through.

Some stuff to check:

1) Really obvious, but I assume your model is positioned so that the sunlight is actually shining through the windows in sketchup?!

2) Set your ghost glass on a single face - don't give it a volume. I believe its one of the 'thin glass' materials that can do this, the others all need to be on a volume. The image below, the glass in the windows is on a single face.

3) The default material in sketchup looks white, but actually renders a sort of grey which can darken scenes a little - change your wall coverings to a white material (but not pure 255,255,255 white, knock them down a little, too white and you get fireflies - spots of white in the image - I believe) which may help lighten up the interior.

4) Ditch Reinhard rendering which tends to flatten contrasts and shadows a little - when rendering in Indigo, have a muck about with the cameras in the tone mapping section of the imaging tab (on the right of the screen). My screenshot is an Avantix100CD with 50 ISO which just improves your contrast somewhat.

5) Last thing, particularly with the evaluation version of Indigo - you're rendering at a lower resolution which can sometimes hide the shadow detailing until the image updates a few times, so try leaving it a little longer and see if your sun is more obvious.
Attachments
Ghostglass test.jpg
Avantix100CD, 50ISO, BidirPT

User avatar
Headroom
Indigo 100
Posts: 972
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Problem with windows...

Post by Headroom » Tue Feb 08, 2011 5:07 am

Bosseye wrote: 3) The default material in sketchup looks white, but actually renders a sort of grey which can darken scenes a little - change your wall coverings to a white material (but not pure 255,255,255 white, knock them down a little, too white and you get fireflies - spots of white in the image - I believe) which may help lighten up the interior.
Generally no albedo should be set above 80% reflectance or in essence above 205 for any RGB color component. Materials like this don't exist in nature. Not only does this reduce fireflies but it also reduces the render time.

BurnGamer
Posts: 5
Joined: Mon Feb 07, 2011 2:05 pm

Re: Problem with windows...

Post by BurnGamer » Tue Feb 08, 2011 5:20 am

@Reinuvader

I'm currently using the Bidirectional MLT method.

@Bosseye

1) In fact, the light is supposed to come through the windows on the right (see image below without windows).

2) The ghost glass is set on a single face. Did you apply the ghost glass "paint" on both sides of the face?

3) I already downloaded a material for the walls and I'll change them later, as I don't think it affects the light entering the room.

4) I currently use the "Camera" mode, but I use the Reinhard method too. I'll try different settings

5) The image below has rendered for about the same amount of time and you can clearly see the difference with the scene with windows.
Attachments
Scene without windows.jpg

BurnGamer
Posts: 5
Joined: Mon Feb 07, 2011 2:05 pm

Re: Problem with windows...

Post by BurnGamer » Tue Feb 08, 2011 2:02 pm

Sorry for double post, but I managed to resolved my problem. I downloaded Indigo 2.6.1 and it seems to work. I followed tips provided here and maybe that helped to. Thanks everyone.

Post Reply
7 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests