Could not find map for material named

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
Post Reply
13 posts • Page 1 of 1
User avatar
Bosseye
Posts: 312
Joined: Fri Jan 01, 2010 10:52 pm
Location: Bristol, UK

Could not find map for material named

Post by Bosseye » Thu Jan 13, 2011 4:38 am

Alright all. Me again :)

Ok, so I have a brand new PC, now running 64bit Indigo. Problem is I can't actually render anything from my existing sketchup model files as I get the following message:

"Could not find map for material named"

Helpful eh? Not really. So presumably there is an issue with a certain material, but which one? I've been through the model file in question deleting materials one by one and rendering each time. No joy until suddenly after 90% of the materials are deleted it renders. Aha! I think, I reinstate the last material, won't render, remove it and renders. Solved eh? No. If I then open the original file again and go straight to the problem material and delete it, render....you guess it, same error.

It seems entirely random. Something to do with changing machines?

Edit - and the other thread on this wherever it is, its nothing to do with material names - remember these are all models that rendered fine on my old PC.

User avatar
Bosseye
Posts: 312
Joined: Fri Jan 01, 2010 10:52 pm
Location: Bristol, UK

Re: Could not find map for material named

Post by Bosseye » Fri Jan 14, 2011 12:53 am

Ok, an update. Seems to be an issue with different downloaded indigo textures in different files, so:

File A - its a texture using the brushed metal indigo texture. if I re import the texture I get the error message

NK data path "C:\Programfiles/Indigo Renderer/nkdata/Au.nk" is not valid

But clicking OK to that message lets me render.

File B - Its a floor texture using the Ambar floor tiles Indigo texture that causes the issue, which throws up the following once updated

NK data path "C:\Programfiles/Indigo Renderer/nkdata/fesi2el2.nk" is not valid

Again, clicking OK to that message lets me render.

File C, same Ambar floor tiles texture, same error

File D (and a couple of others), throws up the message

NK data path "C:\Programfiles/Indigo Renderer/nkdata/fesi2el2.nk" is not valid

but lets me render without having to update any textues at all

File E - Its the Beechwood texture this time, if I update it this time no error message is produced and I can render as normal

File F - Oddly, its the Beechwood texture again, update it and this time I get

NK data path "C:\Programfiles/Indigo Renderer/nkdata/fesi2el2.nk" is not valid

but again I can render once I've ok'd the error message.

File G - Again, its the Beechwood texture, if I update it I can render but not before getting BOTH of the above messages, ie

NK data path "C:\Programfiles/Indigo Renderer/nkdata/fesi2el2.nk" is not valid
NK data path "C:\Programfiles/Indigo Renderer/nkdata/Au.nk" is not valid

Got to say, I'm hugely confused. At least I can get to a point where I can render, but whats going on? There is no such nkdata folder on my C Drive, not sure if theres supposed to be?

User avatar
ENSLAVER
Posts: 399
Joined: Tue Feb 20, 2007 1:49 am

Re: Could not find map for material named

Post by ENSLAVER » Fri Jan 14, 2011 2:10 am

Hmm are the files in that actual location? Is is the same location you installed to?

Tried re-installing it, maybe in a different location or drive?

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am

Re: Could not find map for material named

Post by dag » Fri Jan 14, 2011 3:22 am

nkdata folder -> http://rghost.net/3924938
Goes in C:\Programfiles\Indigo Renderer

User avatar
Headroom
Indigo 100
Posts: 987
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Could not find map for material named

Post by Headroom » Fri Jan 14, 2011 5:24 am

dag wrote:nkdata folder -> http://rghost.net/3924938
Goes in C:\Programfiles\Indigo Renderer
And one should mention that is's created/installed there by default.

User avatar
ENSLAVER
Posts: 399
Joined: Tue Feb 20, 2007 1:49 am

Re: Could not find map for material named

Post by ENSLAVER » Fri Jan 14, 2011 4:29 pm

C:\Program Files has a space between program and files.

User avatar
Bosseye
Posts: 312
Joined: Fri Jan 01, 2010 10:52 pm
Location: Bristol, UK

Re: Could not find map for material named

Post by Bosseye » Fri Jan 14, 2011 9:02 pm

Thanks for the thoughts everyone - fixed it now.

I wasn't aware, but my IT guy had somehow installed Indigo to run over the network (don't ask me, its all black magic) or something along those lines, so it wasn't physically present on my machine - which means the folder C:\Programfiles\Indigo Renderer didn't exist which means the data which is put in that folder on install was missing, including all the nkdata. Ran the installation again, this time it creates the folder on my C drive, lo and behold it all works.

Thanks again all, your thoughts helped me suss the issue - although really, I should have twigged straight away when I couldn't find that folder in the first place. Dumkopff! :oops:

So just waiting on a licence reset then...

User avatar
Alex Pisarev
Posts: 8
Joined: Wed Feb 16, 2011 11:32 pm
Location: Russia, Saint-Petersburg

Re: Could not find map for material named

Post by Alex Pisarev » Thu Feb 17, 2011 2:45 am

when you see that error message just turn on the Ruby console than export again and you`ll see what exact texture is missing
ps I spend a lot of time to figure it out :roll:
Best regards from Russia!

Quick
Posts: 1
Joined: Fri Feb 25, 2011 2:15 am

Re: Could not find map for material named

Post by Quick » Fri Feb 25, 2011 2:28 am

Alex Pisarev wrote:when you see that error message just turn on the Ruby console than export again and you`ll see what exact texture is missing
ps I spend a lot of time to figure it out :roll:
I was having the same issue so found this topic...the above works fine in identifying the problem but it does it every time I open a file...is there an auto fix in the works or was this our files? My files worked fine until I bought the new computer...I thought it was because I went from NVidia to ATI...not sure now though.

User avatar
Alex Pisarev
Posts: 8
Joined: Wed Feb 16, 2011 11:32 pm
Location: Russia, Saint-Petersburg

Re: Could not find map for material named

Post by Alex Pisarev » Fri Feb 25, 2011 8:30 am

No it`s not becouse you bought a new one. Just problem with wrong path to the image/material. You need to fix it. Whithout ruby console it is problematic.
Best regards from Russia!

User avatar
Alex Pisarev
Posts: 8
Joined: Wed Feb 16, 2011 11:32 pm
Location: Russia, Saint-Petersburg

Re: Could not find map for material named

Post by Alex Pisarev » Fri Feb 25, 2011 8:43 am

I did not hear about how to auto fix this, but I think maybe you should try to export your model partly to the new one to find what exact is wrong. Try to render it there. Mostly the problem is with the path
Best regards from Russia!

User avatar
Frutiger
Posts: 122
Joined: Wed May 05, 2010 4:05 am
Location: Northern California

Re: Could not find map for material named

Post by Frutiger » Thu Apr 07, 2011 6:36 pm

I'm been getting a similar set of error messages. The eventual fix was to reinstall my os, sketchup and indigo and then retexture the entire model, but it worked!

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am

Re: Could not find map for material named

Post by dag » Fri Apr 08, 2011 7:15 am

Oh, now we know what to do next time we get that error.
Good shit!

Post Reply
13 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest