problem with indigo shader

Announcements, requests and support regarding the MAYA exporter
Post Reply
8 posts • Page 1 of 1
puntotoprinci
Posts: 6
Joined: Thu Oct 30, 2008 9:04 pm

problem with indigo shader

Post by puntotoprinci » Thu Oct 30, 2008 11:03 pm

hi newly, this is my problem, please help me if you can:

when i export a scene with maya material all work fine, but when I put into the scene an indigo shader...this is the result:

in the output window: Error getting shader

in the script editor: Writing Materials...
// Error: No object matches name: indigoShader4.normalCamera //
select -r indigoShader4 ;
select -r indigoShader4 ;
delete;


Why?

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Post by CTZn » Fri Oct 31, 2008 12:19 am

Welcome puntotoprinici !

What Maya and MtI versions do you use ?

Well I have no immediate answer, I'd bet on a broken scene scenario... but broken indigoShader is a possible thing, though it has shown to be working here. I'm not qualified with python plugins :(

This error is unexpected... ah, was the plugin loaded ? Maybe you loaded a previously created scene when the py plugin was not available in paths (like after installing a new version of Maya) ?

Here an indigoShader has a normalCamera slot for bump by default, so I am a bit surprised...
obsolete asset

puntotoprinci
Posts: 6
Joined: Thu Oct 30, 2008 9:04 pm

Post by puntotoprinci » Fri Oct 31, 2008 1:37 am

Hi CTZn, the Maya version is the 8.5 and the Indigo the 1.0.9.3

I've tried with a blank scene, when I load a new scene and I put the indigo shader into the Hypershade the exporter doesn't work.

Yes, the plug-in was loaded..it's so strange..

Tnx for your attenction

Hellstorm
Posts: 41
Joined: Mon Sep 22, 2008 9:31 pm
Location: Einbeck, Germany
Contact:

Post by Hellstorm » Fri Oct 31, 2008 2:04 am

What MtI-Version do you use?
You should always use the latest version of Indigo and MtI.

puntotoprinci
Posts: 6
Joined: Thu Oct 30, 2008 9:04 pm

Post by puntotoprinci » Fri Oct 31, 2008 2:07 am

but MayaToIndigoInstaller-1093-win ins't the latest version?

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Post by CTZn » Fri Oct 31, 2008 11:52 am

1.0.9_3 is the latest stable exporter version, yes. I will make a package of the last registered version so you can reinstall everything and run the latest Indigo version, new features are currently in progress, a darn slow one :oops:

The error seems to be caused bu the shader plugin, not the exporting process. I guess your copy of the plugin is somehow corrupted or wrongly installed (you need to have python 2.4 installed on your system too), since it creates the indigoShader and it's atttributes, including normalCamera.

Expect a new package release this week-end, with no new features as of today, I'm messing with code for them... I managed to keep my local version running despite this work, and this is good news already :D
obsolete asset

puntotoprinci
Posts: 6
Joined: Thu Oct 30, 2008 9:04 pm

Post by puntotoprinci » Fri Oct 31, 2008 9:02 pm

Tnx CTZn, you've made a great work with indigo, I'be not any problem to wait for new release.

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Post by CTZn » Sat Nov 01, 2008 12:17 am

Ok, I'll have to precise it over and again: I was mostly a spectator of the creation of MtI, i've made like 5% of it only :)

The actual working things are due to Benedikt Kircher and, for the biggest and most recent part, Doug Hammond (I am Adam Penalver). I am learning mel with MtI atm, and python (indigoShader) is still out of my scope...

But I will be happy to make MtI progress, just I'm a hobbyist not a coder yet :)
obsolete asset

Post Reply
8 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest