HDRI

Announcements, requests and support regarding the MAYA exporter
Post Reply
9 posts • Page 1 of 1
BWETIK
Posts: 23
Joined: Tue Jan 23, 2007 7:29 pm

HDRI

Post by BWETIK » Sat Dec 01, 2007 4:32 am

Hi, I trying indigo, and trying use hdri, but it making an error:

SceneLoaderExcep: TinyXmlWrapper: could not find element "gamma" in element "rgb" (around line 35)

What I doing wrong?? I need put the hdri file in some folder, but i dont remember in which one...in to testscenes??

And what about using Indigo materials (from nkdata) in maya?? In blender it was via names of mat....
or is it possible assign it in xml file??

Thanks a lot. Casper. :roll:

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Post by dougal2 » Sat Dec 01, 2007 4:50 am

Hi casper,

Are you using the current release of MtI?
You've probably found a bug with the HDRI export, I don't think that part has been thoroughly tested. I will have a look later and post an update. (there's another bug that needs fixing, so I'll do them both - unless someone else beats me to it).

For now, if you open up the generated XML file and add

Code: Select all

<gamma>2.2</gamma>
into the <rgb> part of the code where the HDRI image is given (around line 35 in your case), it should get you going.

As for .nk data, you need to assign a phong shader to an object in maya, go to hypershade, select the shader, check "nkdata" on the MtI GUI and click "add". This will add a custom nkdata attribute to the shader under "Extra Attributes". there you can select the .nk file to use.

Hope that helps. Sorry for the bugs.

BWETIK
Posts: 23
Joined: Tue Jan 23, 2007 7:29 pm

Thanks

Post by BWETIK » Sat Dec 01, 2007 5:16 am

Nk data working, good (not materials under..cola bottle glass etc..??)
But im not sure what you mean, where put this gamma?? it still not working...or I doing it wrong...
Thanks a lot!!


<env_map>
<lat_long>
<path>C:/Breta_prace/HDRImaps/hdri_new/ennis.hdr</path>
<width>512</width>
<gain>0.9</gain>
</lat_long>
</env_map>

BWETIK
Posts: 23
Joined: Tue Jan 23, 2007 7:29 pm

nk

Post by BWETIK » Sat Dec 01, 2007 5:24 am

And why all nk data looking the same?? transparency with blue in the midle...??? :shock:

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Post by CTZn » Sat Dec 01, 2007 6:53 am

Hello Casper,

only opaque nkdata do work with Indigo, maybe you tried a transparent one wich will not work; it's not related with MtI.

As for gamma error I can't help you cause I don't use hdri... maybe try adding that gamma line under <gain> (or maybe any place inside <lat_long>).

If that doesn't work maybe attach the xml/igs to your post, or post it from beginning to materials definition. If you have no advanced text editor, last resort is to count every line to n°35 and see where you find yourself.
Hi, I trying indigo, and trying use hdri, but it making an error:

Code: Select all

SceneLoaderExcep: TinyXmlWrapper: could not find element "gamma" in element "rgb" (around line 35)
Nothing tells clearly that it is related with HDRI.

Cheers
obsolete asset

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Post by dougal2 » Sat Dec 01, 2007 7:31 am

I've made a quick video about using nk data with MtI

http://www.ftlfm.com/gallery/v/MtI/vidt ... a.flv.html
(edit: updated URL)

it got a little bit corrupted, but I hope you can still follow it.
Last edited by dougal2 on Sat Dec 01, 2007 9:15 am, edited 1 time in total.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Thanks

Post by dougal2 » Sat Dec 01, 2007 8:06 am

I now know the problem.

Code: Select all

<env_map>
	<lat_long>
	<path>C:/Breta_prace/HDRImaps/hdri_new/ennis.hdr</path>
	<width>512</width>
	<gain>0.9</gain>
	</lat_long>
</env_map>
should read

Code: Select all

<env_map>
	<latlong>
	<path>C:/Breta_prace/HDRImaps/hdri_new/ennis.hdr</path>
	<gain>0.9</gain>
	</latlong>
</env_map>
(also, <width> isn't necessary in <latlong> maps. did you add that manually? it's not in the current version on MtI :? )

I'm working on MtI now and will provide an updated version soon.

BWETIK
Posts: 23
Joined: Tue Jan 23, 2007 7:29 pm

Thanks!!

Post by BWETIK » Sun Dec 02, 2007 1:45 am

Ye, env_map now working :D ...or working just exr file not hdr, but its fine... Thanks!

But with nk data its falling, using just Al, Cu, Au...
but, or maybe too much polys?? just 4 triangulated spheres from maya...
xml is generated quickly... dont know...

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Mon Dec 03, 2007 4:40 am

wait...
since when, hdr is supposed to work?
The only HDR formats, Indigo can use, are exr and float, AFAIK

Post Reply
9 posts • Page 1 of 1

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest