Maya to Indigo XML converter

Announcements, requests and support regarding the MAYA exporter
User avatar
ThatDude33
Posts: 216
Joined: Wed Jul 05, 2006 1:26 pm
Contact:

Post by ThatDude33 » Mon Aug 14, 2006 2:27 am

yeah... but the UI is the exact same as it was :?
Matt B. >>Maya To Indigo<<
Image

User avatar
ThatDude33
Posts: 216
Joined: Wed Jul 05, 2006 1:26 pm
Contact:

Post by ThatDude33 » Mon Aug 14, 2006 3:36 am

arne, your version got messed up, splitting it up... now when Indigo runs and etc... either the camera is messed up (even on Z upvector) or I get a constant black or green screen :?



:cry: :oops:
Matt B. >>Maya To Indigo<<
Image

User avatar
arneoog
Indigo 100
Posts: 504
Joined: Sun Jun 25, 2006 2:19 am
Location: Norway
Contact:

Post by arneoog » Mon Aug 14, 2006 3:54 am

doh! :x :oops:
I'll fix it right away! know what's wrong.. heh Very Sorry :o

Edit: Should be fixed now... download from the same link :)
Arne OOG - My Portfolio

User avatar
ThatDude33
Posts: 216
Joined: Wed Jul 05, 2006 1:26 pm
Contact:

Post by ThatDude33 » Mon Aug 14, 2006 4:31 am

ok :) lol, we are having the exact same conversation at both forums :P

recoding in speculars :roll:
Matt B. >>Maya To Indigo<<
Image

User avatar
ThatDude33
Posts: 216
Joined: Wed Jul 05, 2006 1:26 pm
Contact:

Post by ThatDude33 » Mon Aug 14, 2006 4:39 am

oh damn, you DO need to split it up, the size of the script exceeds the limit of the script editor!!!!!!!! :shock:

I have room for 6 more letters and that's it :shock:
Matt B. >>Maya To Indigo<<
Image

User avatar
arneoog
Indigo 100
Posts: 504
Joined: Sun Jun 25, 2006 2:19 am
Location: Norway
Contact:

Post by arneoog » Mon Aug 14, 2006 4:58 am

wow! :shock:
This is almost cool, hehe :D
If we have two files (mtiMain.mel and mtiGen.mel)
and put only the part from "//-----------------TIEING SCRIPTS------------------"
and down into the mtiGen.mel
And delete that part in mtiMain.mel it should work perfectly :)

Remember to have this at the top (under credits) in mtiMain.mel
//-----------------VECTOR CONFIG------------------

global proc vector normalize(vector $v){
float $len = sqrt($v.x*$v.x+$v.y*$v.y+$v.z*$v.z);
vector $n = <<$v.x/$len, $v.y/$len, $v.z/$len>>;
return $n;
}
It's working prefectly here :D
Arne OOG - My Portfolio

polygon
Posts: 2
Joined: Wed Aug 23, 2006 2:20 am
Contact:

Post by polygon » Wed Aug 23, 2006 3:02 am

hello.

I'm maya user and i like maxwell but with export from maya maxwell has got a lot of problems. I look forward to final version Wink. *THUBS UP*

polygon
Posts: 2
Joined: Wed Aug 23, 2006 2:20 am
Contact:

Post by polygon » Wed Aug 23, 2006 3:49 am

Exporter cannot work. I have made all by you help but when i click on Generate XML that when converter make meshes maya hack, procesor have got 100%. What is it ?

User avatar
arneoog
Indigo 100
Posts: 504
Joined: Sun Jun 25, 2006 2:19 am
Location: Norway
Contact:

Post by arneoog » Wed Aug 23, 2006 4:57 am

Stylish! not many Maya users around here :D

About the Exporter:
It is slow, I will recommand to not have more than 20000/30000 tris at the most!
Maya will probably seem to go down the toilet if you got over 20000 tris, but it is stil working :)
And you need to set the Axis to Z, no matter what...
We will be fixing a lot of stuff, but it takes time :) sorry :P

Hope this helped alittle :D
Arne OOG - My Portfolio

User avatar
ThatDude33
Posts: 216
Joined: Wed Jul 05, 2006 1:26 pm
Contact:

Post by ThatDude33 » Thu Aug 24, 2006 12:49 am

my computer is fried... or I would work on it... but I am only on my dad's laptop now :roll: :x :cry:
Matt B. >>Maya To Indigo<<
Image

User avatar
arneoog
Indigo 100
Posts: 504
Joined: Sun Jun 25, 2006 2:19 am
Location: Norway
Contact:

Post by arneoog » Thu Aug 24, 2006 1:25 am

oh... That explaines your deadness :P heh...
What happend to your computer? Too much Indigo Rendering? :( :?

I'll start do some scripting very soon :D
Hope you get your computerproblem sorted :)
Arne OOG - My Portfolio

User avatar
arneoog
Indigo 100
Posts: 504
Joined: Sun Jun 25, 2006 2:19 am
Location: Norway
Contact:

Post by arneoog » Thu Aug 24, 2006 8:17 am

I got some new Design and feature ideas for this thing 8)
So I will be planing those out tonight, then start scripting tomorrow :D (hopefully)

School just started some days ago, so the scripting will get somewhat slower... ...and I will get more tierd...
but that's not a reason to stop :P

Well, I'm going to bed now... ...and start my planing! :wink:
Cheers! :D
Arne OOG - My Portfolio

User avatar
arneoog
Indigo 100
Posts: 504
Joined: Sun Jun 25, 2006 2:19 am
Location: Norway
Contact:

Post by arneoog » Sat Sep 02, 2006 5:12 am

I've now done a lot of UI upgrades and I'm almost finish with the "Save XML directly option" (.xml) :D It is working!!!
Plus I got the Setting Config panel to save its .txt setting file 8)
Still got trouble with the "Render from Maya option", though...
Arne OOG - My Portfolio

Post Reply
28 posts

Who is online

Users browsing this forum: No registered users and 1 guest