Non ascii character in Cindigo output

Announcements, requests and support regarding the Cinema 4D exporter
Post Reply
5 posts • Page 1 of 1
User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Non ascii character in Cindigo output

Post by suvakas » Sat Jun 28, 2008 10:59 am

Hey Fused,
I'm doing some igm tests here and dotNet parser goes crazy about your name in comments of Cindigo exported igm files. :lol:
I think it doesn't like the é character. Could you replace it with a regular e? I can't find a way how to set up the parser to ignore the comments. It does some kind of syntax check before the parsing.

User avatar
PureSpider
Posts: 1459
Joined: Tue Apr 08, 2008 9:37 am
Location: Karlsruhe, BW, Germany
Contact:

Post by PureSpider » Sat Jun 28, 2008 10:27 pm

It's the same with the PHP parser...
I first utf8-decode the file before parsing, then it works ;)

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Post by suvakas » Sat Jun 28, 2008 11:49 pm

Actually yeah, this issue is deeper than just this e of fused. There could be non ascii chars in any igm file.
Anyway..problem solved, You can keep the letter Fused :wink: :)

User avatar
fused
Developer
Posts: 3479
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Sun Jun 29, 2008 1:31 am

oh thank you :)

indeed. igs/igm by cindigo should be UTF-8.

User avatar
PureSpider
Posts: 1459
Joined: Tue Apr 08, 2008 9:37 am
Location: Karlsruhe, BW, Germany
Contact:

Post by PureSpider » Sun Jun 29, 2008 2:05 am

It IS UTF8 ^^
The thing I do is un-UTF8 it first ^^

Post Reply
5 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest