Cindigo 0.9 - beta 1

Announcements, requests and support regarding the Cinema 4D exporter
User avatar
Zom-B
1st Place 100
Posts: 4676
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Fri Aug 10, 2007 2:36 am

Pickman wrote:The Meshlights seem to use the backside of the Polygons to emit light in this Version (very simple scene with 2 planes).
Indigos mesh lights only emits light where the normals are facing at.... so just turn them!
Pickman wrote:I can't get the Exporter to export an exit portal. Or is there some trick to use them?
yes I had to second that.... exit portals seem not to be exported.
polygonmanufaktur.de

Pickman
Posts: 3
Joined: Fri May 18, 2007 3:19 am

Post by Pickman » Fri Aug 10, 2007 2:43 am

ZomB wrote:Indigos mesh lights only emits light where the normals are facing at.... so just turn them!
Its not really a Problem, yes, but this is different to the last version of the exporter (where it worked as you would expect), and as the nornal calculation was changed in this version, so it might be a sign that something bigger is wrong - maybe all normals are flipped? I don't know how to test for that, but at least for the meshlights its definitely a bug.

I'm not complaining, the exporter works nice otherwise (except for the portals ;)).

User avatar
fused
Developer
Posts: 3580
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Fri Aug 10, 2007 2:51 am

will have a look at it. exit portals worked fine for me, though...

edit: heh, commented them out :P

Pickman
Posts: 3
Joined: Fri May 18, 2007 3:19 am

Post by Pickman » Fri Aug 10, 2007 6:51 am

fused wrote:edit: heh, commented them out :P
At least that's easy to fix. :D

User avatar
fused
Developer
Posts: 3580
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Fri Aug 10, 2007 10:41 am

its fixed, want an update?

object heirarchy isnt fixed yet, so it might be kind of pointless...

kadajawi
Posts: 257
Joined: Wed Mar 07, 2007 7:40 am

Post by kadajawi » Sat Aug 11, 2007 2:11 am

Yeah, great :D Gotta try out those exit portals. Oh wait, no, I'm sitting behind a Mac. Ah well, never mind, when I'm back I hope the hirarchy is working :)

User avatar
Zom-B
1st Place 100
Posts: 4676
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Sat Aug 11, 2007 2:20 am

fused wrote:its fixed, want an update?
object heirarchy isnt fixed yet, so it might be kind of pointless...
Fell free for an silent Update without version number change ;-)
Don't forget that news about your exporter gets spread all over net!
People not only in this Forum use it.

About the Exit Portals, I think you could put them into the light tag, no need for an extra Icon imo. Ono once told that its an Light material thing... so... bah, really not that important ^^
polygonmanufaktur.de

User avatar
Zom-B
1st Place 100
Posts: 4676
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Sat Aug 11, 2007 11:25 am

Looool..... found a new bug ^^
(no idea how somebody couldn't find this)

While Export all normals get flipped for me.... inside => Out

I attached the WinOSi Testscene I just played with so you can see for yourself...


BTW: I discovered that not only BumpMaps don't get exported, but no texture gets exported!
Tiled textures get exported wrong. a 4 times tiled texture gets exported 8 times tiled!

I updated the Buglist on the first page of this thread.
Attachments
WinOSi.zip
(28.93 KiB) Downloaded 127 times
polygonmanufaktur.de

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Sat Aug 11, 2007 10:13 pm

ZomB wrote:Looool..... found a new bug ^^
(no idea how somebody couldn't find this)
While Export all normals get flipped for me.... inside => Out
two days earlier:
Pickman wrote:... but this is different to the last version of the exporter (where it worked as you would expect), and as the nornal calculation was changed in this version, so it might be a sign that something bigger is wrong - maybe all normals are flipped? I don't know how to test for that, but at least for the meshlights its definitely a bug.
:wink:

User avatar
Zom-B
1st Place 100
Posts: 4676
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Sun Aug 12, 2007 1:55 am

lol, I really missed this post :oops:
polygonmanufaktur.de

Micha1138
Posts: 28
Joined: Mon Aug 07, 2006 2:45 am

Post by Micha1138 » Tue Aug 14, 2007 7:26 am

Hi folks,

looks really promising ! No real project at the moment to test the exporter out effectively, and not really a lot time on hand for just fooling around with it, but that can change in a heartbeat ;)

Fused, keep those implementations coming, I´ll spread the word as fast and good as I can ;)

Thanks again and a lot,
Michael

User avatar
fused
Developer
Posts: 3580
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Wed Aug 15, 2007 6:32 am

update!

-------------------------------------------------------

CINDIGO 0.9 - BETA 1

download exporter:
PC Version

(or below)

The file contains PC versions for R10 and R9. (R10 users will have to rename the "cindigo0.9.1.cdl_R10" to "cindigo0.9.1.cdl")

No Mac version to come, sry.

please tell me if you find bugs or have specific requests. i will try to fix/implement as fast as possible.

new in 0.9 - beta 1:

* exit portals


fixed-list 0.9 - beta 1:

* normal issue solved
* exit portals working now
* hierarchy gets exported now


known bugs/issues 0.9 - beta 1:

* only UVW-mapping supported


please post bugs :!: :!:


a good tutorial can be found here (only german and italian, hope someone will translate it to english soon).

extraextra: a little baking tutorial
Attachments
cindigo0.9b1_2.zip
Cindigo 0.9 beta 1
(454.16 KiB) Downloaded 192 times

User avatar
Zom-B
1st Place 100
Posts: 4676
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Wed Aug 15, 2007 7:23 am

thank you a lot dude! :D

*starts testing*
polygonmanufaktur.de

User avatar
Zom-B
1st Place 100
Posts: 4676
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Wed Aug 15, 2007 8:45 am

1) gamma tag is still missing in background, absorption_coefficient_spectrum, scattering_coefficient_spectrum and RGB Light. (take care to set default gamma to 1 in some situations!)

2) Phase function gets exported wrong! it is:

Code: Select all

<phase_function>
  <uniform>
    <value>0.9</value>
  </uniform>
</phase_function>
but it should be:

Code: Select all

<phase_function>
   <uniform/>
</phase_function>
*edited after Ono mentioned*

3) normals for me get still flipped on export :? (see attached file)

4)
Still got the older bug that stuff gets exported on wrong xyz cordinates (see attached file)

5) Advanced > Export Settings to XML.... change this to igs ;-)

6) Phong materials get always RGB 0.85 0.85 0.85 exported, the chosen color gets ignored.


Here is the Example Scene.


Requests


1) For Lighttype (background, env map & sun) "off" should be added, for no background lightning!

2) Light Type backround can be Black Body peak etc. too!

3) Lighttype "peak" can have the following parameters (see manual!)
- peak_min
- peak_max
- peak_width
- base_value
- peak_value
*maybe this is outdated?!?*

4) Exponent maps

5) Texture Emitters

6) shutter_open_duration

7) ray_origin_nudge_distance

8 ) halt_samples_per_pixel

9) change default Cindigo "max_num_consec_rejections" & "max_depth" to Indigo default values.

10) a b c control for bump Maps
Last edited by Zom-B on Fri Aug 17, 2007 3:35 pm, edited 3 times in total.
polygonmanufaktur.de

ilanb
Posts: 3
Joined: Wed Aug 15, 2007 7:16 pm

message error

Post by ilanb » Wed Aug 15, 2007 7:21 pm

Hi,

First thanks for this great work :shock: very impressive !
I test your plugin and scene file but after export when I open .igs file, I have this error message :

Sceneloaderexcept : TinyXmlWarrper : could not find element 'gamma' in element 'rgb' (around line 31'

Could you help me to resolve this ?

Thanks again

C4D version : 10.111 pc
indigo : V09_test6
cindigo0.9b1_2
scene : 0.9.1_test.c4d

Post Reply
157 posts

Who is online

Users browsing this forum: Google [Bot] and 3 guests