Cindigo 0.8 - beta 2

Announcements, requests and support regarding the Cinema 4D exporter
User avatar
Marcofly
Posts: 407
Joined: Thu Jun 29, 2006 12:51 am
Location: Köln, Germany

Post by Marcofly » Wed May 23, 2007 2:43 am

pinko, what don't you understand about making base-mats with cindigo?

have you read the cindigo tutorial, the indigo manual, the examples in the forum?

User avatar
Zom-B
1st Place 100
Posts: 4663
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Wed May 23, 2007 2:45 am

A realy great release fused, the redone material Tag is wonderfull!

At this moment finding bug becomes really hard for me.... you did a great job!
I only found one single new:

1) for the OBJ export you export a <material_name> Tag inside the <externa> Tag.
This one is useless, because the material name is taken from the OBJ material name definition!


I don't know about your plans for cindigo, but I think it would be nice to tweak this lovely Plugin to maximize the usability with complex Scenes. There are still issues and restrictions for Scenes that use lot of null Object tree strukture (Verschachtlungen)

fused wrote:and.... pls spread the news to all other forums you know :) (would do it myself but im lazy)
I'm regularly posting all Indigo News over at c4dboard.com, so the Indigoaners over there know :wink:
polygonmanufaktur.de

User avatar
Pinko5
Posts: 497
Joined: Mon Feb 19, 2007 8:15 pm
Location: Italy

Post by Pinko5 » Wed May 23, 2007 3:45 am

@ Marcofly ...look PM
Tnx
Pinko.

okazaky
Posts: 57
Joined: Thu Aug 31, 2006 5:30 am

Post by okazaky » Wed May 23, 2007 9:36 pm

Thx fused! Can't wait to test it this evening :)

User avatar
Marcofly
Posts: 407
Joined: Thu Jun 29, 2006 12:51 am
Location: Köln, Germany

Post by Marcofly » Thu May 24, 2007 4:17 am

Hi fused: the exporter works very well, the gui improvement is very good!
i found only two things:
-bigger scenes: sometimes the camera and the settings don't get exported at all. the only thing that worked was putting the camera and the null_object with the settings at the beginning of the object list. will test it further..

-null objects with children don't get exported: i get crazy everytime i have to make a scene setup: how can we loose this problem? the hierarchy is very important, for bigger scenes, as you know..

a wip to test cindigo and my new pc..
Attachments
6_1_6.jpg
6_1_6.jpg (120.82 KiB) Viewed 2289 times

User avatar
fused
Developer
Posts: 3558
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Thu May 24, 2007 9:10 am

im working on that at the moment, still dont really have a clue why it doesnt work (it should, at least i think so). im also making some improvements to .obj export (optimkzing output file size and speed)

User avatar
Marcofly
Posts: 407
Joined: Thu Jun 29, 2006 12:51 am
Location: Köln, Germany

Post by Marcofly » Thu May 24, 2007 9:55 am

fused, i found this, don't know if it can be useful. if you have a tree like this:

null object (no tag)
null object (no tag)
object1 (no tag)
object2 (no tag)
object3 (light tag)

the light gets correctly exported.

the other thing you should think about is the texture mapping (other than uvw)..
hope i'm not asking too much.. unfortunately i have no idea about codes and programming, so i can't help you much..

thank you very much!!
Marcofly

User avatar
fused
Developer
Posts: 3558
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Thu May 24, 2007 5:28 pm

yes this helps, thank you!

edit: well, object 1 and 2 have Object tags, dont they? if not its absolutely no help :P

texturemapping should be no problem, but(!) the thing is that i have no idea how to acces the TexData in the Ttexture tag. unfortunately the docs are very unclear on that

User avatar
fused
Developer
Posts: 3558
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Thu May 24, 2007 7:15 pm

i just found out how the uvw tag works :P (that one has always been a mysterium for me)

ill write a small workaround tut for texture mapping over the weekend (it will be about baking procedurals, too)

edit: works very well, as you can see (i implemented bump on specular, new release coming soon)
Attachments
im1179990714.JPG
bump mapping on specular with a baked procedural
im1179990714.JPG (112.2 KiB) Viewed 2245 times

User avatar
Zom-B
1st Place 100
Posts: 4663
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Fri May 25, 2007 5:49 am

Hey fused...
I just rechecked all bugs I found before, and did a new list, also with new stuff I found:

1) phase_function is implemented wrong, it allways gets exported

Code: Select all

<phase_function>
      <uniform />
</phase_function> 
this means no phase_functionality (or a zero functionality?!?)

But phase_function could be uniform using a value like:

Code: Select all

<phase_function>
      <uniform>0.33</uniform>
</phase_function>
or even a not uniform rgb value like:

Code: Select all

<phase_function>
   <rgb>
      <rgb>0.2 0.3 0.4</rgb>
   </rgb>
</phase_function>
The Henyey Greenstein phase_function can be RGB too... still not fixed :P

2) if no "indigo settings tag" exists, the camera doesn't get exported.

3) for diffuse_transmitter you use a special exponent setting.... why don't take the existing for textures you already implemented?!

4) for the OBJ export you export a <material_name> Tag inside the <external> Tag.
This one is useless, because the material name is taken from the OBJ material name definition!

5) Instancing on sphere Primitives don't work

6) Specular & glossy_transparent materials need a medium, but it may be deactivated in your exporter, throwing a error in Indigo.

7) Bump Maps get exported to XML even if they where deactivated in the Material settings of C4D's Material Editor.

8 ) It seems a Object Tag on a no-polygon object like hyper Nurbs, null object etc. exports a empty obj file, that crashers indigo.
Also tree hierarchy gets totally ignored :(

9) I can remember that in version 0.7x an object tag on a Hyper nurb correctly exported the (subdivided) mesh that was attached to the hypernurb.
Now the Object tag don't convert c4d primitives and other objects to polygone mesh like before, but it exports an empty obj file with correct materials set.

10) The rotation Bug is still there, here a sample Scene.
(file was not natively created in C4D, perhaps this info helps)

11) Instancing of interlocked (verschachtelt) object doesn't work,
the (mesh) child of a mesh parent doesn't get exported...
Also instancing of null_objects containing mesh information doesn't work.

12) Rotation of instanced Objects gets ignored.

13) In this example Scene the room walls use not the defaultMat
(no material applied in C4D so they have to use defaultMat!),
but another material containing in the scene!
Strange, because the igs & obj files seem to use defaultMat :?: :?: :?:
(maybe a Indigo Bug!)

14) In some situations the obj export just clamp the material name after the first word => Example Scenefile.
So my material called "shiny ground texture" gets exported right in the igs,
but in the obj file its only named "shiny" => Indigo throws an error about a undefined material

15) Materials that are exported without the material link in the "indigo material tag",
gets exported to igs with the material name "MATERIAL LINK NOT SET!".
(instead of using deafultMat for the exported meshes, a alert material could be used.... like pink :wink: )
But for blended materials that has no such linkage, the blend material exported uses the name defaultMat, overiding the gray diffuse standard defaultMat!

16) A Material like specular or glossy transparent, that uses medium, exports this medium even if it get changed to diffuse or phong etc.

17) The Tile settings & texture Offset values for UVW mapped Textures don't get exported.

18 ) You sure know, but the normal length normalising, that Indigo does for you, totally sucks for big Meshes!!!!!
80MB normalize for ~26min using only one core :cry: My Hair2mesh2Indigo test are some freakin pain in the ass...
**EDIT** workaround this issue by reopening the exported OBJ Files in C4D and export them as Wavefront OBJ file size gets reduced to ~65% of the original filesize, BUT NORMAL SMOOTHING GETS DISABLED!!!

19) The new "chose indigo folder" request, that prompts after first start choses a the wrong folder (one hierarchy higher), also the cindigo.config is written in the Maxon PlugIn folder not in the Folder of cindigo...


Here are some missing features:

1) Instances should be able to have different material settings from their parent!
2) Exponent Map implementation missing.
3) a, b and c values for every type of textures (see updated manual)
4) Multiple blending of (already blendet) materials **EDIT** works already perfect.... my mistake :oops:
5) Support for multiple textures on a single mesh
6) Background can also be disabled, also light options for background mode are missing (blackBody, peak
etc.)


Here some ideas about (layout) optimization of you exporter and stuff:

1) In the indigo "render settings tag", advanced could be a own tab for better overview.
2) Internal_medium could use some clean up too, like the basic material you already did.
hemoglobine & melanin stuff should be available for dermis/epidermis stuff only.
also all the SSS related stuff should be only availible if SSS is activated.
3) internal medium should be availible ONLY for materials that supports it.Default Naming should be materialname_medium.
4) How about using the C4D OBJ export for all meshes that have normal smoothing disabled, so this would workaround the normalisation issue...
5) "Export igs only" would come handy if you just play around with your material settings, would save some time


BTW: you could give your self some credit in the exported igs in the first lines after Exporter version :wink:
Last edited by Zom-B on Thu Jun 14, 2007 9:10 am, edited 14 times in total.
polygonmanufaktur.de

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Fri May 25, 2007 8:17 am

diffuse_emitter?
Do you mean _transmitter?

User avatar
Zom-B
1st Place 100
Posts: 4663
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Fri May 25, 2007 8:25 am

eeeeeeehhhhhmmm....yes!

corected...
polygonmanufaktur.de

User avatar
fused
Developer
Posts: 3558
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Fri May 25, 2007 8:35 am

thank you very much ZomB!

1) uniform can have a value? really? O.o

2) FIXED

3) it was kind of experimental. fixed

4) FIXED

5) not? strange...

6) i was just about to fix that :P also if you change the mat from spec to phong and had medium activated the medium got exported too

7) uhm, ok will fix that

8 ) well to be honest: i have no clue - edit: :lol: 8) ^^

9) yeah, i changed some things in obj export - better: i changed everything in obj export

missing features:
1) dont think this is possible in my exporter at the moment (would have to recode lots of stuff)
2) coming soon
3) thanks, i never really knew what those are for
4) should work?
5) maybe

and thank you for your thoughts on the layout. you are definately the best beta tester one could have :)

User avatar
Marcofly
Posts: 407
Joined: Thu Jun 29, 2006 12:51 am
Location: Köln, Germany

Post by Marcofly » Fri May 25, 2007 8:46 am

ZomB is definitely THE beta tester!

:lol:

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Fri May 25, 2007 9:55 am

yup.

@ZomB:
can't you test the other Exporters, too? :P

Locked
111 posts

Who is online

Users browsing this forum: No registered users and 1 guest