Geometry disappears when rendering

Announcements, requests and support regarding the Cinema 4D exporter
Post Reply
6 posts • Page 1 of 1
blomfelt
Posts: 3
Joined: Fri Feb 16, 2018 5:30 am

Geometry disappears when rendering

Post by blomfelt » Fri Feb 16, 2018 5:36 am

Hi there,

I'm working on my final diploma project studying architecture and I've started to have serious issues in some of my scenes. When rendering large portions of my scene disappears. Depending on what I turn on and off in C4D, different things aren't shown and are cut off oddly. I've attached some images showing what happens & a screenshot from the editor of what should be shown.

I'm on Mac with the latest version of OSX, Indigo Renderer 4.0.65 and Cindigo 4.0.64.

Thanks!

Mikael
Attachments
Screen Shot 2018-02-15 at 18.26.20.jpg
Screen Shot 2018-02-15 at 18.26.32.jpg
Screen Shot 2018-02-15 at 18.32.48.jpg

User avatar
Oscar J
1st Place Winner
Posts: 2165
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Geometry disappears when rendering

Post by Oscar J » Fri Feb 16, 2018 5:43 am

Nice catch! I had this bug once a while ago I think. Could you upload the scene for the developers to look at?

User avatar
Originalplan®
Posts: 733
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Geometry disappears when rendering

Post by Originalplan® » Fri Feb 16, 2018 6:01 am

Hello @blomfelt nice to hear you going with Indigo for your diploma project.
Your issue inside C4D seems very familiar to me..did you use a cloner as a base for your setup?
Try to make the cloner editable and see if it helps with the issue.

blomfelt
Posts: 3
Joined: Fri Feb 16, 2018 5:30 am

Re: Geometry disappears when rendering

Post by blomfelt » Fri Feb 16, 2018 7:09 am

Indigo is great, best 150 Euros spent!

I'm an idiot and forgot to mention that the basis for the model was built in Sketchup Pro 2017 and then imported which obviously always causes a huge mess. I spent an hour cleaning it up but there are still loads of nested groups. We've recently switched to C4D for a lot of the modelling but some of the earlier models were done in Sketchup before we realised how good the integration is with Cindigo and how C4D handles lots of polygons without breaking a sweat. I've attached the scene, I'd like to understand what is wrong before I keep working on it.


Thanks for the quick replies guys!
Attachments
Eisschmelze.c4d.zip
(1.32 MiB) Downloaded 23 times

blomfelt
Posts: 3
Joined: Fri Feb 16, 2018 5:30 am

Re: Geometry disappears when rendering

Post by blomfelt » Sat Feb 17, 2018 4:46 am

So it seems like the problem was due to how C4D handles the import of Sketchup files. When I export a .3ds from Sketchup and open that instead it renders without an issue.

User avatar
Originalplan®
Posts: 733
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Geometry disappears when rendering

Post by Originalplan® » Sat Feb 17, 2018 8:59 pm

Nice to hear that the problem is solved.
I downloaded your project and it exported fine from R19 to latest Indigo.
Not sure if you are running R19 too, but if you get a chance give it a try it works very well with Indigo.

Nice to have you in the community & feel free to reach out with any questions you might got in the future.

OP

Post Reply
6 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest