Indigo for Cinema 4D 4.0.43

Announcements, requests and support regarding the Cinema 4D exporter
User avatar
arc en ciel
Posts: 138
Joined: Tue Apr 12, 2016 2:33 am

Re: Indigo for Cinema 4D 4.0.43

Post by arc en ciel » Fri Aug 05, 2016 9:40 am

I'm sorry but on win 8 c4d r16, the exporter 4.0.43 converts every external mat to a simple diffuse mat without any parameters.
All is fine with exporter 4.0.42.

User avatar
fused
Developer
Posts: 3549
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo for Cinema 4D 4.0.43

Post by fused » Fri Aug 05, 2016 11:03 am

arc en ciel wrote:I'm sorry but on win 8 c4d r16, the exporter 4.0.43 converts every external mat to a simple diffuse mat without any parameters.
All is fine with exporter 4.0.42.
Dang. Will fix for next.

User avatar
Originalplan®
Posts: 733
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Indigo for Cinema 4D 4.0.43

Post by Originalplan® » Fri Aug 05, 2016 9:50 pm

fused wrote:
Originalplan® wrote:It works like also like a Render region???Wow.
No, but I was thinking about doing that :)
I was just surprised by it. :)
All in all IMO is better to have the PR Render in a separate window.
Makes things more uncomplicated and simple. PR Render region would be cool as a technical feat but does not make much sense since EDIT & FEEDBACK is the purpose. And for editing a scene in C4D viewport you have to be able to see what you are doing and having a render region constantly ON would just complicate things.

++If we can sync up the PR Render window with the actual camera view ( sensor size and focal length ) i think we have a very strong plugin for Indigo. ( And i'm pretty sure in September with the R18 and updated viewport performance enhancements you can speed it up more )
+++ stabilizing the PR Renders performance a bit. It works surprisingly well now...no crashes or whatsoever.
The only thing i observed is that sometime i can get it using very small steps in the camera's x,y,z to render constant feedback's...jumping huge amount's (in data / scene) makes it black and calculate a bit to show the PR render view. But i still think it's a superb start and all can be fixed pretty much.

OKIRO Indigo :!:

User avatar
fused
Developer
Posts: 3549
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo for Cinema 4D 4.0.43

Post by fused » Sat Aug 06, 2016 3:57 am

Just got a ~2-3x speed up on mesh export. Thanks to nick :)

Also fixed the external materials.

And perfect spheres.

Maybe another release at the end of the day.

User avatar
yonosoy
Posts: 477
Joined: Sat Dec 01, 2012 9:45 pm
Location: Spain

Re: Indigo for Cinema 4D 4.0.43

Post by yonosoy » Sat Aug 06, 2016 4:01 am

Thank you very much for all the effort and success!
"... the hamster don't see the wheel, and this wasn't said before." (yoS eidaN "el Olvidao")
"... nor 0.2 galaxys, nor 0.8 little chikens ..."

User avatar
fused
Developer
Posts: 3549
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo for Cinema 4D 4.0.43

Post by fused » Sat Aug 06, 2016 6:36 am

Originalplan® wrote:++If we can sync up the PR Render window with the actual camera view ( sensor size and focal length ) i think we have a very strong plugin for Indigo. ( And i'm pretty sure in September with the R18 and updated viewport performance enhancements you can speed it up more )
You mean it should have the same aspect ratio as the selected render resolution?
Originalplan® wrote:+++ stabilizing the PR Renders performance a bit. It works surprisingly well now...no crashes or whatsoever.
The only thing i observed is that sometime i can get it using very small steps in the camera's x,y,z to render constant feedback's...jumping huge amount's (in data / scene) makes it black and calculate a bit to show the PR render view. But i still think it's a superb start and all can be fixed pretty much.
I fixed the issue with the black image being shown and made it quite a bit more responsive.

Updating while you are moving the camera in the viewport might be tricky. I'm not getting any messages from c4d while the user interacts with the camera. Maybe there is a way, need to look into it more.

User avatar
Originalplan®
Posts: 733
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Indigo for Cinema 4D 4.0.43

Post by Originalplan® » Sat Aug 06, 2016 7:37 am

You mean it should have the same aspect ratio as the selected render resolution?
Originally ( when i first tested it yesterday that was the first thing that came to mind ) the PR render should have the same aspect ration as the active camera in your scene. ((have a look at the screenshot))
But now after using it for a while it's 100% logical and it isn't weird anymore...
Maybe an indicator like safe area and tinted boarder color?? Not sure just was weird at first but than again you can always check the viewport for that info....
I fixed the issue with the black image being shown and made it quite a bit more responsive.
Mr.fused you are on fire! :D How can so manny things be solved in a day.. PRO work.
Updating while you are moving the camera in the viewport might be tricky. I'm not getting any messages from c4d while the user interacts with the camera. Maybe there is a way, need to look into it more.
Well it works now for a couple of small moves.

+Another topic i was woderin about. PR render view now runs with an -1 spp setting?? Or does it stop somewhere? Maybe it's not necessary (you will know this better than me) but would it be snappier if it had an SSP
scale that is exponentially calculated / sec ? Indigo Mat preview has the 64-128-256-512-1024-2048 spp rates selectable. So would such an integrated spp scale speed Cindigo up? Or once it renders it renders..end of story?:)
Attachments
Screen Shot 2016-08-05 at 9.00.24 PM.jpg
:) Not sure....both are good.

User avatar
arc en ciel
Posts: 138
Joined: Tue Apr 12, 2016 2:33 am

Re: Indigo for Cinema 4D 4.0.43

Post by arc en ciel » Sat Aug 06, 2016 10:06 am

gamma value of an image can not be changed, it's always 2.2 in Indigo
tested with 4.0.42 and 4.0.43
Attachments
gamma.jpg

User avatar
thesquirell
Posts: 380
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Indigo for Cinema 4D 4.0.43

Post by thesquirell » Sun Aug 07, 2016 3:34 am

confirming gamma export problem.

User avatar
contegufo
Posts: 517
Joined: Tue Aug 11, 2015 8:41 am
Location: Lucca ITALY
Contact:

Re: Indigo for Cinema 4D 4.0.43

Post by contegufo » Sun Aug 07, 2016 5:29 am

I confirm that any change in C4D Gamma is ignored by IndigoRenderer remaining fixed to the value of 2.2.
It might be interesting to add the possibility of rotation of the texture of 90 °.
Mac Mini 2011 - 2,3 GHz Intel Core i5
16 GB 1333 MHz DDR3 - Intel HD Graphics 3000 512 Mb.
Samsung SSD 860 EVO 500GB - MacOS Sierra 10.13.6



https://www.behance.net/Paolo_Conti

User avatar
thesquirell
Posts: 380
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Indigo for Cinema 4D 4.0.43

Post by thesquirell » Sun Aug 07, 2016 6:35 am

It would be pretty neat to have accsess to Indigo's transformations from the Cindigo's GUI (tilling/position/rotation).

User avatar
Originalplan®
Posts: 733
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Indigo for Cinema 4D 4.0.43

Post by Originalplan® » Sun Aug 07, 2016 7:30 am

thesquirell wrote:confirming gamma export problem.
Yep confirm here to..gamma exp prob.Stuck on 2.200000645

Got two crashes via PR render today. Please let me know if you guys's need the BUG report filed or not.

User avatar
fused
Developer
Posts: 3549
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo for Cinema 4D 4.0.43

Post by fused » Sun Aug 07, 2016 7:38 am

Originalplan® wrote:
thesquirell wrote:confirming gamma export problem.
Yep confirm here to..gamma exp prob.Stuck on 2.200000645

Got two crashes via PR render today. Please let me know if you guys's need the BUG report filed or not.
Ideally, steps to reproduce and if you have a scene file. Bugreport *can* be useful.

User avatar
Originalplan®
Posts: 733
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Indigo for Cinema 4D 4.0.43

Post by Originalplan® » Sun Aug 07, 2016 7:45 am

fused wrote:
Originalplan® wrote:
thesquirell wrote:confirming gamma export problem.
Yep confirm here to..gamma exp prob.Stuck on 2.200000645

Got two crashes via PR render today. Please let me know if you guys's need the BUG report filed or not.
Ideally, steps to reproduce and if you have a scene file. Bugreport *can* be useful.
Steps :
1. Switching back from active GPU (Both) to CPU when PR is running. Selected camera active in your scene.
2. Stopping PR render. Deactivate the cam and zooming in closer to the model ( no cam selected )
3. Starting up PR again....and Boom crash.

Not sure this helps.?

User avatar
thesquirell
Posts: 380
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Indigo for Cinema 4D 4.0.43

Post by thesquirell » Sun Aug 07, 2016 9:54 am

fun fact: emission's gamma is fixed at 1, which is actually good!

Post Reply
39 posts

Who is online

Users browsing this forum: No registered users and 1 guest