Indigo 2.0.9

General News and accouncements regarding the Indigo render engine
User avatar
OnoSendai
Developer
Posts: 6083
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Indigo 2.0.9

Post by OnoSendai » Fri Jun 26, 2009 1:39 pm

Hi all, just a small bugfix release.

This is a Beta release.
If you spot any bugs or problems, please make a post about them in this thread.
Thanks!

Indigo for Windows 32-bit:
IndigoRenderer_2.0.9_Setup.exe

Indigo for Windows 64-bit:
IndigoRenderer_x64_2.0.9_Setup.exe

Linux 32-bit:
indigo_v2.0.9.tar.gz

Linux 64-bit:
indigo_x64_v2.0.9.tar.gz

Changelog:
2.0.9
* Fixed loading of scene resolution into GUI in included scene files.

User avatar
cpfresh
Posts: 501
Joined: Thu Jun 14, 2007 12:20 pm
Location: California, USA
Contact:

Re: Indigo 2.0.9

Post by cpfresh » Fri Jun 26, 2009 2:21 pm

Thanks Ono :)

User avatar
OnoSendai
Developer
Posts: 6083
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo 2.0.9

Post by OnoSendai » Fri Jun 26, 2009 5:47 pm

Added Linux builds.

User avatar
WytRaven
Indigo 100
Posts: 905
Joined: Mon Aug 27, 2007 8:24 pm
Location: Dubbo, Australia
Contact:

Re: Indigo 2.0.9

Post by WytRaven » Fri Jun 26, 2009 6:24 pm

OnoSendai wrote:Added Linux builds.
Is this fix not applicable to Mac 2.0.8 or is the build just yet to come?

User avatar
Jambert
Indigo 100
Posts: 545
Joined: Wed Jul 30, 2008 10:08 pm
Location: France, Lyon

Re: Indigo 2.0.9

Post by Jambert » Sat Jun 27, 2009 12:40 am

OnoSendai wrote:Added Linux builds.
Thanks :)

SzLaszlo
Posts: 123
Joined: Sun Aug 03, 2008 1:04 am
Location: Budapest / Hungary

Re: Indigo 2.0.9

Post by SzLaszlo » Sun Jun 28, 2009 5:25 am

Yes ,good work :)

( ubuntu linux 9.04. 64bit )

User avatar
Zom-B
1st Place 100
Posts: 4547
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo 2.0.9

Post by Zom-B » Sun Jun 28, 2009 8:45 am

just a tiny bug:

error message for region rendering and a bigger x1 than x2 is:

Code: Select all

Error: render region x1 must be 
A little short, don't you think?! :)

User avatar
Pibuz
1st Place 100
Posts: 2607
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Indigo 2.0.9

Post by Pibuz » Wed Jul 01, 2009 1:01 am

Updated! Thank you!
I report here a little..problem. I think Indigo (and Skindigo) always names the first two light layers as Sun (the first) and Sky (the second).
That is incorrect sometimes. I'm now playing with a test scene in which I deactivated (sketchUp's) sun and sky, and I've lit my scene with two emitters. Now, during the rendering, it results that my right emitter (which I've set to be in Layer 0) is the Sun and my left emitter (which I've set to be in Layer 1) is the Sky. It made me laugh a little, but it could lead to misunderstandings.

So, I thought: probably sun and sky layers should be disabled (= completely not exported) if disabled during the scene export phase; OR we could add the possibility to customize the layers' names, leaving Sun and Sky as the default names for the first two layers. So, in case, one could just change the name and then everything would be ok.

Just 2 cents.

EDIT:
I'M SO SORRY GUYS! Apparently SkIndigo CAN ALREADY do what I suggested..
Maybe I set the scene in an older version and did not check the automatic update of the layers' names.. Sorry Whaat!
Attachments
screenshot.jpg
screenshot.jpg (331.39 KiB) Viewed 5439 times
Last edited by Pibuz on Wed Jul 01, 2009 1:37 am, edited 1 time in total.

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Re: Indigo 2.0.9

Post by suvakas » Wed Jul 01, 2009 1:08 am

@Pibuz
That's actually something for Whaat to solve. You can rename sky / sun layers or any other light layer in Indigo. So this is Skindigo issue and not Indigo.

User avatar
Pibuz
1st Place 100
Posts: 2607
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Indigo 2.0.9

Post by Pibuz » Wed Jul 01, 2009 1:09 am

OPS! Sorry!
Shall I remove the post?

User avatar
ROUBAL
Indigo 100
Posts: 78
Joined: Mon Nov 20, 2006 10:31 am
Location: FRANCE
Contact:

Re: Indigo 2.0.9

Post by ROUBAL » Thu Jul 02, 2009 8:18 pm

Thank you.

Just tested indigo 2.0.9 with Blendigo 2.0.9 :

The renders folder located in the Application data path remains empty on my system. Even with Indigo 2.0.9.

I really need an autosave for png/and or igi files.

Do you plan to include this feature in a close future ?

As it existed in versions before 2.0.6, I think that it wouldn't be too hard to put it again... and it's so necessary !

Thanks in advance.

Philippe.

Windows XP Pro SP2.

User avatar
pixie
Indigo 100
Posts: 2058
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo 2.0.9

Post by pixie » Thu Jul 02, 2009 8:29 pm

ROUBAL wrote:Thank you.

Just tested indigo 2.0.9 with Blendigo 2.0.9 :

The renders folder located in the Application data path remains empty on my system. Even with Indigo 2.0.9.

I really need an autosave for png/and or igi files.

Do you plan to include this feature in a close future ?

As it existed in versions before 2.0.6, I think that it wouldn't be too hard to put it again... and it's so necessary !

Thanks in advance.

Philippe.

Windows XP Pro SP2.
Don't worry they are still being saved, it's somewhere on the c:\documents and settings\username\app data

I'm on windows 7 so I can't point you more precisely

User avatar
ROUBAL
Indigo 100
Posts: 78
Joined: Mon Nov 20, 2006 10:31 am
Location: FRANCE
Contact:

Re: Indigo 2.0.9

Post by ROUBAL » Fri Jul 03, 2009 11:32 am

I know that the former renders directory has been removed (it was also always empty since indigo 2.0.6)

I have good reasons to worry : The renders directory is at the location you give me, but it remains empty and nothing is saved in it.

Suvakas already gave me the location of the folder,
but the directory in Documents and Settings/Application Data/User Name/indigo renderer/renders is always empty !

User avatar
pixie
Indigo 100
Posts: 2058
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo 2.0.9

Post by pixie » Fri Jul 03, 2009 12:28 pm

ROUBAL wrote:I know that the former renders directory has been removed (it was also always empty since indigo 2.0.6)

I have good reasons to worry : The renders directory is at the location you give me, but it remains empty and nothing is saved in it.

Suvakas already gave me the location of the folder,
but the directory in Documents and Settings/Application Data/User Name/indigo renderer/renders is always empty !
It's due tp ypur exporter I'm afraid... mine is populated,but then it's the default procedure for cindigo.

Pick a cinema 4d demo, install quicktime and cindigo plugin, you'lll see that igs will be saved

User avatar
ROUBAL
Indigo 100
Posts: 78
Joined: Mon Nov 20, 2006 10:31 am
Location: FRANCE
Contact:

Re: Indigo 2.0.9

Post by ROUBAL » Fri Jul 03, 2009 12:37 pm

you'lll see that igs will be saved
Do you mean igi? igs are related to the exporter, but igi are related to indigo.

Post Reply
20 posts

Who is online

Users browsing this forum: DotBot [Bot] and 2 guests