Indigo v1.0.9 for Linux Build 2

General News and accouncements regarding the Indigo render engine
User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Indigo v1.0.9 for Linux Build 2

Post by OnoSendai » Wed Apr 09, 2008 7:35 pm

Changed parsing code to fix weird parsing error,
statically linking with OpenEXR

x64:
http://www.indigorenderer.com/joomla/in ... &Itemid=62

32 bit:
http://www.indigorenderer.com/joomla/in ... &Itemid=62
Last edited by OnoSendai on Sun Jun 01, 2008 3:03 pm, edited 1 time in total.

User avatar
SmartDen
Developer
Posts: 999
Joined: Fri Oct 13, 2006 10:58 pm
Location: Canary Islands
Contact:

Post by SmartDen » Wed Apr 09, 2008 8:01 pm

thanks!
Check normals, dude!

Image
Image

Vanessa07
Posts: 312
Joined: Mon Sep 24, 2007 11:17 pm
Location: Suisse

Post by Vanessa07 » Wed Apr 09, 2008 9:08 pm

Thx Ono :D

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Wed Apr 09, 2008 10:08 pm

hooray!! work great now - thanks 8)

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Post by OnoSendai » Thu Apr 10, 2008 12:50 am

Ok.. so which versions are working for people?
If you got a version working, please tell me 32 or 64 bits and console or GUI or both.

User avatar
alenofx
Posts: 14
Joined: Sun Jul 29, 2007 2:24 am
Contact:

Post by alenofx » Thu Apr 10, 2008 2:47 am

Works fine here on ArchLinux 32 bit, both console and GUI version. :D
Note: on the same OS, the Windows version with Wine 0.9.59 is a bit faster than the native Linux version. :roll:

User avatar
Grimm
Posts: 119
Joined: Sun Dec 09, 2007 7:38 pm
Location: Fairbanks, Alaska, USA

Post by Grimm » Thu Apr 10, 2008 2:53 am

Hi Ono,

I got the same error for the 64bit version as I did before:
indigo_x64_linux_v1.0.9_2]$ ./indigo
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
Aborted
The console version works great. The distro I'm using is Fedora 8.

The 32bit version has the same issue.
Grimm

User avatar
Macrob
Posts: 289
Joined: Sat Feb 24, 2007 9:55 am

Post by Macrob » Thu Apr 10, 2008 3:28 am

Grimm: You are using both (32, 64) versions on one computer? Which arch?
2.8 is the required version of gtk(?).
If so try to upgrade gtk(+) (on your own risk ;) )

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Thu Apr 10, 2008 3:58 am

the 32bit version (console + gui) on ubuntu hardy is working great here.
only the scrollbar problem (as dougal already reported) is still there.

unimportant stuff:
- some testscenes are broken cause the refer to e.g. "al.nk" instead of "Al.nk" (case-sensitive issue)
- no icon

User avatar
Grimm
Posts: 119
Joined: Sun Dec 09, 2007 7:38 pm
Location: Fairbanks, Alaska, USA

Post by Grimm » Thu Apr 10, 2008 4:48 am

Thanks Macrob,

My arch is a AMD X2 4000 dual core. According to yum I'm updated to the latest versions, at least as far as the repositories are concerned. :) .

Maybe I'm running a version that is too new?
yum list gtk2
Installed Packages
gtk2.i386 2.12.5-1.fc8 installed
gtk2.x86_64 2.12.5-1.fc8 installed
yum list wxGTK
Installed Packages
wxGTK.i386 2.8.4-6.fc8 installed
wxGTK.x86_64 2.8.4-6.fc8 installed
Grimm

User avatar
Macrob
Posts: 289
Joined: Sat Feb 24, 2007 9:55 am

Post by Macrob » Thu Apr 10, 2008 5:13 am

nope, I´ve got

gtk+ 2.12.8
wxGTK 2.8.

on an AMD X2 4400+ and it works.
Perhaps try a live-dvd of another distro to find the problem (?).

Are there other fedora users? I could not install fedora due to a bug :cry:

User avatar
Macrob
Posts: 289
Joined: Sat Feb 24, 2007 9:55 am

Post by Macrob » Thu Apr 10, 2008 5:28 am

By the way: What about a small list of distros, which are reported to work with the build next to the download link?

Lets start:
Gentoo x64 :wink:

User avatar
Grimm
Posts: 119
Joined: Sun Dec 09, 2007 7:38 pm
Location: Fairbanks, Alaska, USA

Post by Grimm » Thu Apr 10, 2008 5:32 am

I removed the 32bit versions but it didn't make any difference. :( No biggie as I can just run the console version. :wink:
Grimm

User avatar
jurasek
Posts: 247
Joined: Sun Jun 25, 2006 11:23 pm
Location: Poland

Post by jurasek » Thu Apr 10, 2008 5:46 am

indigo_console and .exr works fine with x64 build here (fedora8). Thank you Ono.

greetz,
jur

User avatar
joegiampaoli
Posts: 837
Joined: Thu Oct 05, 2006 7:12 am
Location: San Miguel de Allende-MEXICO
Contact:

Post by joegiampaoli » Thu Apr 10, 2008 6:44 am

32 bit here Ono, both GUI and console seem to work well.

Thanks! Really nice build :D
Joe Giampaoli
Never tie a ship to a single anchor, nor life to a single hope
My Indigo Gallery

Post Reply
65 posts

Who is online

Users browsing this forum: No registered users and 2 guests