Indigo Renderer 4.4.14 Beta

General News and accouncements regarding the Indigo render engine
User avatar
OnoSendai
Developer
Posts: 6225
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Indigo Renderer 4.4.14 Beta

Post by OnoSendai » Wed Sep 23, 2020 4:30 pm

This is a Beta release.
If you spot any bugs or problems, please make a post about them in this thread.
Thanks!

Indigo for Windows 64-bit:
IndigoRenderer_4.4.14_Setup.exe

Indigo for Linux 64-bit:
IndigoRenderer_v4.4.14.tar.gz

Indigo for Mac OS X (10.13 - ):
IndigoRenderer4.4.14.dmg


Indigo RT for Windows 64-bit:
IndigoRT_4.4.14_Setup.exe

Indigo RT for Linux 64-bit:
IndigoRT_v4.4.14.tar.gz

Indigo RT for Mac OS X (10.13 - ):
IndigoRT4.4.14.dmg

Changelog:
4.4.13 - 4.4.14
* Fixed non-interactive Indigo (indigo console etc..) not exiting when an error occurs.
* Fixed resuming rendering from IGI while using bucket rendering not working properly.
* Fixed bug where if the extension is not appended to the image save path, indigo gui does not save the image (only happened on linux)
* Made it so that tonemapping/imaging (in particular denoising) can be cancelled part way through.
* Fixed UI lockup when updating layer thumbnails in UI while denoising is taking place.
* On tonemapping, imaging changes etc.., tonemap without denoising initially, then tonemap with denoising 2 seconds later.
Makes changing tonemapping etc.. much more responsive when denoising is enabled.
* MLT: checking if optimise for denoise or bucket rendering is enabled to give error about bucket rendering
* Improved licensing dialog, in particular the online licensing tab.
* Improved speed of grabbing online licence
* Updated Qt version
* Fixed thread affinity error when rendering with more threads than logical cores.
* Fixed issue with setting thread affinity when the number of CPUs in a group is 64.
* Improved handling of base env spectrum with GPU rendering.
* Fixed sun+env map blends working incorrectly on the GPU in some cases.
* Changed way rendering speed is calculated, always works off last pass speed now, instead of overall speed since the start of render for non-bucket rendering.
* Lots of UI improvements 'under the hood'.
* Fixed clipping of text in dock widget titles in dark theme, other theme improvements.
* First entry in theme drop-down box in options dialog on Mac is now "platform appearance" - uses system appearance to decide between light and dark themes.


4.4.12
* Added trace_through_trans_mats_for_channels render setting, true by default.
* Fixes spectral output to work with MLT properly.
* Scaling RGB preview of spectral render channels so they match the usual RGB rendering.

4.4.11
* GPU: Added explicit light connections for SSS, which means IOR 1 participating media work now.
* GPU: Added participating media and SSS render channels.
* Allowing change of initial subresolution when doing CPU bucketed rendering.
* Added GPU support for lightmap baking.
* Added a lightmapping settings section in the render mode settings UI.
* Added some new preset resolutions.
* Added 512*512 resolution option for material previews.
* Optimised media handling. Max num media a ray can be in is now 4 on CPU.
* Fixed bug with wavelength bin begin offset by half the bin width for spectral env maps.
* Changed spectral_output_start_wavelength default value to 390 nm, and spectral_output_bucket_width default value to 310/8, to reflect the new rendering wavelength range.
* Added a bunch more render settings as queue override options, including Save tonemapped/untonemapped EXRs etc.., and render channel options.
* Show the autofocus distance in the focus distance spinbox in the camera controls.
* Fixed OpenGL preview widget not showing anything when shown after a scene has already been loaded.
* Fixed bug with env map rotation showing as zero degrees in some cases.
* Fixed material preview context checks being broken.
* Fixed render mode area getting squashed in UI.
* Fixed double buffering setting (which is on by default) applying to CPU non-bucketed rendering.
* Fixed OpenGL preview not being loaded properly after changing material preview scenes.

User avatar
schwungsau
Posts: 43
Joined: Wed May 02, 2018 5:44 pm
Location: vancouver
Contact:

Re: Indigo Renderer 4.4.14 Beta

Post by schwungsau » Wed Sep 23, 2020 5:54 pm

licence key not working anymore

User avatar
schwungsau
Posts: 43
Joined: Wed May 02, 2018 5:44 pm
Location: vancouver
Contact:

Re: Indigo Renderer 4.4.14 Beta

Post by schwungsau » Wed Sep 23, 2020 5:59 pm

i have one scene where the bucket is gray (locked) out and turn on, it works in 4.8 but in versions later its tell bi-directionla bucket rendering is not supported, but it let turn it off.. if switched render engine a couple of times it works. i can turn it off.


nice QT update !
had de-install it, because if can;t get licence with 4.14

User avatar
Zom-B
1st Place 100
Posts: 4691
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 4.4.14 Beta

Post by Zom-B » Wed Sep 23, 2020 7:57 pm

The license Key should work across all v4 builds, had absolutely no issue with it updating...
You use local license or online one Sau?

User avatar
fused
Developer
Posts: 3636
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo Renderer 4.4.14 Beta

Post by fused » Wed Sep 23, 2020 11:30 pm

schwungsau wrote:
Wed Sep 23, 2020 5:59 pm
i have one scene where the bucket is gray (locked) out and turn on, it works in 4.8 but in versions later its tell bi-directionla bucket rendering is not supported, but it let turn it off.. if switched render engine a couple of times it works. i can turn it off.


nice QT update !
had de-install it, because if can;t get licence with 4.14
The bucket rendering checkbox has a tooltip that tells you why it's either forced on or off.

For gpu rendering, bucket rendering is always on. Same with "optimise for denoise".

Re the license: are you using online license? If yes, try logging out and back in. There were some changes.

Faust07
Posts: 7
Joined: Fri Feb 24, 2017 4:15 am

Re: Indigo Renderer 4.4.14 Beta

Post by Faust07 » Wed Sep 23, 2020 11:41 pm

My indigoRT license key (for v4) no longer works either. The detection engine thinks I have installed the full version of Indigo ...

wob
Posts: 112
Joined: Tue Jan 07, 2020 6:15 pm

Re: Indigo Renderer 4.4.14 Beta

Post by wob » Thu Sep 24, 2020 12:09 am

wow

User avatar
OnoSendai
Developer
Posts: 6225
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Indigo Renderer 4.4.14 Beta

Post by OnoSendai » Thu Sep 24, 2020 12:30 am

Faust07 wrote:
Wed Sep 23, 2020 11:41 pm
My indigoRT license key (for v4) no longer works either. The detection engine thinks I have installed the full version of Indigo ...
Fixed, new build incoming.

User avatar
OnoSendai
Developer
Posts: 6225
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Indigo Renderer 4.4.14 Beta

Post by OnoSendai » Thu Sep 24, 2020 1:03 am

Ok builds have been updated in place with a fixed version. Please redownload and reinstall.

mpro31
Posts: 28
Joined: Fri Jan 05, 2018 9:44 pm

Re: Indigo Renderer 4.4.14 Beta

Post by mpro31 » Thu Sep 24, 2020 1:29 am

Hi OnoSendai,
floating licence does not work in new version
any suggestions?

User avatar
OnoSendai
Developer
Posts: 6225
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Indigo Renderer 4.4.14 Beta

Post by OnoSendai » Thu Sep 24, 2020 2:02 am

mpro31 wrote:
Thu Sep 24, 2020 1:29 am
Hi OnoSendai,
floating licence does not work in new version
any suggestions?
We'll look into it.

User avatar
schwungsau
Posts: 43
Joined: Wed May 02, 2018 5:44 pm
Location: vancouver
Contact:

Re: Indigo Renderer 4.4.14 Beta

Post by schwungsau » Thu Sep 24, 2020 5:02 am

if i load one scene i get this error (see picture).
i can not render with any engine. i can't turn it off until i turn off the denoiser, after i can render.

then, i can go back and turn on the denoiser on again, and render with any engine, but the bucket option goes into lock mode and turns on, which i should not able to be because the bucket flag is on.
Attachments
error.JPG

User avatar
schwungsau
Posts: 43
Joined: Wed May 02, 2018 5:44 pm
Location: vancouver
Contact:

Re: Indigo Renderer 4.4.14 Beta

Post by schwungsau » Thu Sep 24, 2020 5:02 am

licence is now working ! tks.

wob
Posts: 112
Joined: Tue Jan 07, 2020 6:15 pm

Re: Indigo Renderer 4.4.14 Beta

Post by wob » Thu Sep 24, 2020 8:22 am

i tested it just now, and can say, sss improvements are soooo great! looking beautiful. it's possible to create full volumetric environments now with indigo gpu.

p.s. also glad to see the network rendering halt fix not mentioned in changelog list. still waiting for non-script scatter realization...

User avatar
fused
Developer
Posts: 3636
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo Renderer 4.4.14 Beta

Post by fused » Thu Sep 24, 2020 9:18 am

schwungsau wrote:
Thu Sep 24, 2020 5:02 am
if i load one scene i get this error (see picture).
i can not render with any engine. i can't turn it off until i turn off the denoiser, after i can render.

then, i can go back and turn on the denoiser on again, and render with any engine, but the bucket option goes into lock mode and turns on, which i should not able to be because the bucket flag is on.
MLT currently does not work with bucket rendering.

You can use the denoiser with MLT (though, the results may not be great), but you cannot use the "optimise for denoise" option - which implies "bucket rendering", "decorrelated pixel sampling" and the "albedo" and "normal" render channels.

"Optimise for denoise" is only a shortcut for all of these options.

https://www.indigorenderer.com/document ... /denoising

Post Reply
42 posts

Who is online

Users browsing this forum: No registered users and 2 guests