Indigo Renderer 4.0.47 Beta Release

General News and accouncements regarding the Indigo render engine
User avatar
Zalevskiy
Posts: 184
Joined: Thu Jul 16, 2015 12:36 am
Location: Russian Federation

Re: Indigo Renderer 4.0.47 Beta Release

Post by Zalevskiy » Tue Dec 13, 2016 6:17 pm

Update Indigo 4047 Materials Pack
Total 768 Materials [ 1.57GB ] [ Shader 128 Materials ]

Download:
https://yadi.sk/d/NLyR2MTb33KsuL

User avatar
pixie
Indigo 100
Posts: 2212
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4.0.47 Beta Release

Post by pixie » Sat Dec 17, 2016 9:22 am

Where can I get "Measured Materials"?

walnist
Posts: 14
Joined: Thu Nov 19, 2015 2:02 am

Re: Indigo Renderer 4.0.47 Beta Release

Post by walnist » Wed Dec 21, 2016 4:30 am

Hi,
if I enable OpenCL - GPU rendering, OpenCL seems to compile the shader programs, but then I get 0 samples per pixel with my scene, while the sample scenes shipped with Indigo seem to render fine.
To give you a better picture:
Windows 10 64 Bit, nVidia GTX1070 8GB

- My Scene - Indigo 3.8 - CPU - Renders OK
- My Scene - Indigo 3.8 - GPU - Renders OK
- My Scene - Indigo 4 - CPU - Renders OK
- My Scene - Indigo 4 - GPU - Does NOT Render
- Indigo Sample - Indigo 4 - CPU - Renders OK
- Indigo Sample - Indigo 4 - GPU - Renders OK

Unfortunately I cannot send you my scene, but do you have any tips to help me troubleshoot it, any particular materials or flags which are not supported by Indigo 4 - OpenCL - GPU?
Thanks,

User avatar
Oscar J
1st Place Winner
Posts: 2170
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Indigo Renderer 4.0.47 Beta Release

Post by Oscar J » Wed Dec 21, 2016 4:58 am

No clues in the render log?

walnist
Posts: 14
Joined: Thu Nov 19, 2015 2:02 am

Re: Indigo Renderer 4.0.47 Beta Release

Post by walnist » Wed Dec 21, 2016 8:33 pm

Oscar J wrote:No clues in the render log?
Where do I find the render log?

User avatar
pixie
Indigo 100
Posts: 2212
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4.0.47 Beta Release

Post by pixie » Wed Dec 21, 2016 8:35 pm

walnist wrote:
Oscar J wrote:No clues in the render log?
Where do I find the render log?
On the drop down menu
Attachments
Render Log.jpg

walnist
Posts: 14
Joined: Thu Nov 19, 2015 2:02 am

Re: Indigo Renderer 4.0.47 Beta Release

Post by walnist » Wed Dec 21, 2016 10:57 pm

So this is the log:
Building OpenCL scene data.
Licence request connection done, got licence until 600 s from now.
Num buffer layers: 1
Master buffer size: 30.480 MB
Settings:
Image width: 400 px
Image height: 400 px
Supersample factor: 4
Internal image width: 1632 px
Internal image height: 1632 px
Verbose: false
Image save period: 10 s
Splat filter: FastBox
Downsize filter: mn_cubic, blur=1.000, ring=-0.000, support=3.300px
Metropolis: false
Bidirectional: false
Aperture diffraction: true
Post-process diffraction: false
Auto setting number of threads to 12.
Finished initialisation (Time Taken: 1.59 s)
OpenCL code for GeForce GTX 1070 built. (elapsed: 0.4900 s)
OpenCL code for 'diffuse' on GeForce GTX 1070 built. (elapsed: 0.01654 s)
OpenCL code for 'translucent' on GeForce GTX 1070 built. (elapsed: 0.01370 s)
OpenCL code for 'phong_nonbasic_8659449695711977334' on GeForce GTX 1070 built. (elapsed: 0.01801 s)
OpenCL code for 'oren_nayar' on GeForce GTX 1070 built. (elapsed: 0.01554 s)
OpenCL code for 'specular' on GeForce GTX 1070 built. (elapsed: 0.01377 s)
Re-checking network licence: Found valid network floating licence.
Starting threads... (num threads: 12)
Starting render thread. (RNG seed=0)
Optimised OpenCL code for 'diffuse' on GeForce GTX 1070 built. (elapsed: 0.01719 s)
Optimised OpenCL code for 'translucent' on GeForce GTX 1070 built. (elapsed: 0.03871 s)
Exception while advancing OpenCL PT: clEnqueueReadBuffer failed reading bucket: CL_OUT_OF_RESOURCES
OpenCL build program failed. Build log:


So the error seems to be: CL_OUT_OF_RESOURCES
Can it be due to meshes being too complex?

walnist
Posts: 14
Joined: Thu Nov 19, 2015 2:02 am

Re: Indigo Renderer 4.0.47 Beta Release

Post by walnist » Thu Dec 22, 2016 1:03 am

Ok I made some progress: by removing Oren Nayar material, the CL_OUT_OF_RESOURCES error disappears, and the renderer now apparently generates samples.

The problem is the rendered image remains pitch black, it seems the light sources do not work.
As light source i use a diffuse material with RGB base emission properties.

With the same settings, the scene rendered on the CPU is perfectly lit.

User avatar
Oscar J
1st Place Winner
Posts: 2170
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Indigo Renderer 4.0.47 Beta Release

Post by Oscar J » Thu Dec 22, 2016 1:09 am

From your log file it seems you have a "phong_nonbasic_8659449695711977334" material. Not sure what that is? It does build the material, but you see that the CL_OUT_OF_RESOURCES message happens just as it's about to optimise the material code for that material.

Oren Nayar materials definitely works using GPU, so I doubt that's the actual problem here. Try the Reinhard option and see if the render remains black.

walnist
Posts: 14
Joined: Thu Nov 19, 2015 2:02 am

Re: Indigo Renderer 4.0.47 Beta Release

Post by walnist » Thu Dec 22, 2016 2:03 am

Oscar J wrote:From your log file it seems you have a "phong_nonbasic_8659449695711977334" material. Not sure what that is? It does build the material, but you see that the CL_OUT_OF_RESOURCES message happens just as it's about to optimise the material code for that material.

Oren Nayar materials definitely works using GPU, so I doubt that's the actual problem here. Try the Reinhard option and see if the render remains black.
That material was a phong with a shader, and you're right, disabling that made the error disappera.

I've now disabled all shaders, yet the image remains pitch black, even with Reinhard tone mapping.

walnist
Posts: 14
Joined: Thu Nov 19, 2015 2:02 am

Re: Indigo Renderer 4.0.47 Beta Release

Post by walnist » Thu Dec 22, 2016 2:11 am

Ok I found the last error.
Light sources were modeled as Sphere objects.

Replacing that with normal objects, the scene is lit.

So to sum it up, what so far it didn't work in my scene:

- phong material with a shader
- Sphere objects as light source

User avatar
Oscar J
1st Place Winner
Posts: 2170
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Indigo Renderer 4.0.47 Beta Release

Post by Oscar J » Thu Dec 22, 2016 2:24 am

Oh yeah, you can't use sphere primitives in GPU mode at the moment. From http://www.indigorenderer.com/forum/vie ... =1&t=13927

"Sphere primitives not supported currently". Apparently it will be implemented later in the 4.x series.

User avatar
pixie
Indigo 100
Posts: 2212
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4.0.47 Beta Release

Post by pixie » Thu Dec 22, 2016 3:36 am

Oscar J wrote:Oh yeah, you can't use sphere primitives in GPU mode at the moment. From http://www.indigorenderer.com/forum/vie ... =1&t=13927

"Sphere primitives not supported currently". Apparently it will be implemented later in the 4.x series.
one can uncheck the checked option to render perfect
Attachments
sphere.jpg
sphere.jpg (10.26 KiB) Viewed 3100 times

fourzeronine
Posts: 90
Joined: Fri Nov 15, 2013 5:16 pm
Location: Los Angeles, CA
Contact:

Re: Indigo Renderer 4.0.47 Beta Release

Post by fourzeronine » Thu Dec 22, 2016 8:35 pm

Im rendering a scene using network. 1 working master (2 gpus) and one slave rendering with (3 gpus). It seems the slave is only contributing the first 100 spp that it calculates very early in the render and never actually contributes much to the overall render. also in the network rendering tab it shows the slave only doing 900k samples/s where it actually runs the scene much faster than the master with 2 slower gpu's which is getting around 6 million samples/s. It looks like the master is unaware of the progress of the slave and never updates the image before it reaches the 2500 spp. :(

User avatar
Originalplan®
Posts: 737
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Indigo Renderer 4.0.47 Beta Release

Post by Originalplan® » Tue Jan 03, 2017 8:18 am

What's this? Can someone give some advice?
Attachments
Screen Shot 2017-01-02 at 21.09.16.png

Post Reply
71 posts

Who is online

Users browsing this forum: No registered users and 1 guest