Indigo Renderer 4 public beta

General News and accouncements regarding the Indigo render engine
Esenistras
Posts: 6
Joined: Sat Apr 16, 2016 7:22 am

Re: Indigo Renderer 4 public beta

Post by Esenistras » Sat Apr 16, 2016 7:47 am

R9 290
Oscar: only 2,2M s/s
Something is wrong :S

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Indigo Renderer 4 public beta

Post by CTZn » Sat Apr 16, 2016 9:01 am

I spent the evening undoing that :) I once sent you a zipped sequence, the cloud shader should feature the issue after adaptations to 4.0. I can send you the current shader by PM.

In the attached image you can see the error after I swapped the commenting status between the two lines boxed. I must then revert all if-else statement to the old scripture and then the shader works.
Attachments
no else.jpg

User avatar
OnoSendai
Developer
Posts: 6234
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Indigo Renderer 4 public beta

Post by OnoSendai » Sat Apr 16, 2016 9:04 am

CTZn wrote:I spent the evening undoing that :) I once sent you a zipped sequence, the cloud shader should feature the issue after adaptations to 4.0. I can send you the current shader by PM.

In the attached image you can see the error after I swapped the commenting status between the two lines boxed. I must then revert all if-else statement to the old scripture and then the shader works.
In this case, try adding a 'then' token:

For example:

if a then b else c

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Indigo Renderer 4 public beta

Post by CTZn » Sat Apr 16, 2016 9:12 am

OnoSendai wrote:
CTZn wrote:I spent the evening undoing that :) I once sent you a zipped sequence, the cloud shader should feature the issue after adaptations to 4.0. I can send you the current shader by PM.

In the attached image you can see the error after I swapped the commenting status between the two lines boxed. I must then revert all if-else statement to the old scripture and then the shader works.
In this case, try adding a 'then' token:

For example:

if a then b else c
Ah thank you, I didn't know about the 'then' statement ! That worked indeed.

User avatar
OnoSendai
Developer
Posts: 6234
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Indigo Renderer 4 public beta

Post by OnoSendai » Sat Apr 16, 2016 9:28 am

CTZn wrote: Ah thank you, I didn't know about the 'then' statement ! That worked indeed.
It's optional, and only required in some places where the grammar is ambiguous.

User avatar
Oscar J
1st Place Winner
Posts: 2200
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Indigo Renderer 4 public beta

Post by Oscar J » Sat Apr 16, 2016 9:52 am

Esenistras wrote:R9 290
Oscar: only 2,2M s/s
Something is wrong :S
Yes, that's definitely lower than expected. Are you running the latest drivers? Are you using your GPU for your display - if so, are there any other processes running?

User avatar
Tramis
Posts: 64
Joined: Fri Aug 08, 2014 11:52 am

Re: Indigo Renderer 4 public beta

Post by Tramis » Sat Apr 16, 2016 9:54 am

I made few tests with Halt SSP. I set the limit 200, but as you can see in the picture it passed the limit. Dunno why.

Btw in the future it would very advantageous to be able to compress images (Low, Medium, High, like photoshop and other image editing apps has).
Attachments
image_compression.jpg
image_compression.jpg (34.04 KiB) Viewed 7923 times
chair4.0.31.jpg
chair3.8.31.jpg

User avatar
Oscar J
1st Place Winner
Posts: 2200
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Indigo Renderer 4 public beta

Post by Oscar J » Sat Apr 16, 2016 9:57 am

Tramis: Odd about the halt spp thing. Regarding image compression: Indigo has that under Image Saving in Preferences:
Attachments
Screen Shot 2016-04-15 at 23.55.48.png

User avatar
OnoSendai
Developer
Posts: 6234
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Indigo Renderer 4 public beta

Post by OnoSendai » Sat Apr 16, 2016 9:59 am

Hi Tramis,
You can set the Jpeg quality in the options dilaog.

User avatar
Tramis
Posts: 64
Joined: Fri Aug 08, 2014 11:52 am

Re: Indigo Renderer 4 public beta

Post by Tramis » Sat Apr 16, 2016 10:02 am

lol >_>

I checked the wrong Indigo version, yes Indigo 4 have this option, thx guys.
Last edited by Tramis on Sat Apr 16, 2016 10:07 am, edited 1 time in total.

User avatar
OnoSendai
Developer
Posts: 6234
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Indigo Renderer 4 public beta

Post by OnoSendai » Sat Apr 16, 2016 10:05 am

Tramis: that looks like Indigo 3.8, it was introduced in Indigo 4.

User avatar
Tramis
Posts: 64
Joined: Fri Aug 08, 2014 11:52 am

Re: Indigo Renderer 4 public beta

Post by Tramis » Sat Apr 16, 2016 10:09 am

OnoSendai wrote:Tramis: that looks like Indigo 3.8, it was introduced in Indigo 4.
Yes Ono, I opened the wrong Indigo settings. >_> me nub

User avatar
Zom-B
1st Place 100
Posts: 4698
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 4 public beta

Post by Zom-B » Sat Apr 16, 2016 10:18 am

Esenistras wrote:R9 290
Oscar: only 2,2M s/s
Something is wrong :S
Sounds to me like you are maybe using old drivers?! What version is installed?
Double-check that you only use the GPU for rendering and not the together with the CPU!
Also if you can, please monitor GPU usage during rendering... you also need to wait at least 3-4 min until s/sec stabilized!

Esenistras
Posts: 6
Joined: Sat Apr 16, 2016 7:22 am

Re: Indigo Renderer 4 public beta

Post by Esenistras » Sat Apr 16, 2016 11:31 am

OK my computer reached 100% RAM usage (16GB) and Vram usage (5338MB VRAM pikes)...
I'm using latest driver (non-WHQL 16.4.1).
I also tried with all programs closed (chrome, anti-virus ect).
Attachments
indigo.jpg

User avatar
Oscar J
1st Place Winner
Posts: 2200
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Indigo Renderer 4 public beta

Post by Oscar J » Sat Apr 16, 2016 11:45 am

Did you try waiting a little longer?

Post Reply
560 posts

Who is online

Users browsing this forum: No registered users and 4 guests