Indigo Renderer 3.8.0 Beta Release

General News and accouncements regarding the Indigo render engine
FakeShamus
Posts: 509
Joined: Wed May 02, 2007 11:34 am

Re: Indigo Renderer 3.8.0 Beta Release

Post by FakeShamus » Sun Feb 23, 2014 9:55 am

Zom-B wrote:Also test if this error with your scene is happening also with non BiDir render modes, since the 3.8 update has a lot of changes for BiDir...
ok interesting - yes, just tried switching to regular pathtracing, no BiDir, and everything is running totally smoothly.

bgpitts
Posts: 1
Joined: Sun Feb 23, 2014 6:04 pm
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by bgpitts » Sun Feb 23, 2014 6:07 pm

speedup is great, but I have problem with slaves

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Indigo Renderer 3.8.0 Beta Release

Post by CTZn » Thu Mar 06, 2014 5:00 am

Great speedups indeed !

A couple ISL issues I noted down:

- posOS() is not working, in scattering shaders at least.

- off the top of my head scattering and absorbtion shaders can not access the material's shared data. Perhaps should they be allowed to access all shared data from the medium's material(s), or allow mediums to bear data.

Adding params to mediums (MtI allows to do this) would crash Indigo upon calling its shaders editors.

Please clarify the data usage under these circumstances.

I'm very much expecting the announced MLT upgrade !

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Indigo Renderer 3.8.0 Beta Release

Post by CTZn » Thu Mar 06, 2014 5:13 am

Also, could the following be explained ?
* Shader eval functions, and some others, now require an 'env' argument of type 'opaque'. Old shaders will be automagically fixed up.
How can I get to the new pyroclastic noise ? It looks like a reverse ridged noise, is it ?

FakeShamus
Posts: 509
Joined: Wed May 02, 2007 11:34 am

Re: Indigo Renderer 3.8.0 Beta Release

Post by FakeShamus » Fri Mar 07, 2014 10:08 am

I was just getting another error with a scene that works fine with the previous, stable version. the scene opens but gives an error when I start the render. the error reads:

Code: Select all

Error while building scene: Error while loading emission scales: No material with UID 42 assigned to model. (model UID: 124)
it was related to a material that was attached to my object but not assigned to any faces, but I couldn't find any reference in my scene files regarding material or model UID numbers, so it was difficult to tell what was causing the problem. like I said, the scene works fine in 3.6.26, so something changed in the handling of materials, it seems like? at least a specific material name in the error message would have helped a lot.

and, separately, can we get a check box for emitter materials to enable the back-face emit option? and in Blendigo as well, while I'm asking...

thanks.

tar_gniK
Posts: 152
Joined: Wed Apr 13, 2011 7:36 pm
Location: London, UK
3D Software: 3ds Max
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by tar_gniK » Sun Mar 09, 2014 9:41 pm

Code: Select all

Scene parsing error: Failed to open XML doc from path 'F:\MaxigoTemp\Abstract_Night-scene.igs': Could not determine tag type: Line 8, column 2.
XML around error:
<!====== RENDER SETTINGS ======>
Works as expected in 3.6.26 but not 3.8.

User avatar
OnoSendai
Developer
Posts: 6184
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by OnoSendai » Sun Mar 09, 2014 9:53 pm

tar_gniK wrote:

Code: Select all

Scene parsing error: Failed to open XML doc from path 'F:\MaxigoTemp\Abstract_Night-scene.igs': Could not determine tag type: Line 8, column 2.
XML around error:
<!====== RENDER SETTINGS ======>
Works as expected in 3.6.26 but not 3.8.
We changed the XML parser in 3.8 to something much faster.

Unfortunately <!====== RENDER SETTINGS ======> is invalid XML. if you edit the file you could remove the line, as it's just a comment.

tar_gniK
Posts: 152
Joined: Wed Apr 13, 2011 7:36 pm
Location: London, UK
3D Software: 3ds Max
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by tar_gniK » Tue Mar 11, 2014 1:28 am

Thanks, Ono, will do so.

User avatar
Ludwolf76
Posts: 22
Joined: Sun May 30, 2010 3:31 am
Location: Viareggio, Italy

Re: Indigo Renderer 3.8.0 Beta Release

Post by Ludwolf76 » Fri Mar 14, 2014 9:34 pm

Hi...I have problems with network rendering with this version of Indigo...TCP connection failed between slave and master...with previous releases everything was ok!!!
Bye...

neo0.
Posts: 1784
Joined: Thu Feb 28, 2008 7:11 am
Location: the US of A

Re: Indigo Renderer 3.8.0 Beta Release

Post by neo0. » Sat Mar 15, 2014 7:31 pm

o_0 The new glass acceleration is freaking awesome! I had some lightbulbs and they were comming out black. I turned on glass acceleration and they instantly rendered clearer when i restarted the render.

User avatar
Zom-B
1st Place 100
Posts: 4682
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by Zom-B » Sat Mar 15, 2014 10:29 pm

neo0. wrote:I had some lightbulbs and they were comming out black...
I hope you understand that black lightbulbs are 99,9% chance of bad modeling, rather then Indigo doing something wrong...

neo0.
Posts: 1784
Joined: Thu Feb 28, 2008 7:11 am
Location: the US of A

Re: Indigo Renderer 3.8.0 Beta Release

Post by neo0. » Mon Mar 17, 2014 5:37 am

Zom-B wrote:
neo0. wrote:I had some lightbulbs and they were comming out black...
I hope you understand that black lightbulbs are 99,9% chance of bad modeling, rather then Indigo doing something wrong...
This is what I assumed but the lightbulbs have thickness and when i turned on glass acceleration, they become see through like they should almost instantly like I said. :)
Attachments
default2.jpg

User avatar
Zom-B
1st Place 100
Posts: 4682
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by Zom-B » Mon Mar 17, 2014 5:48 am

Double check the normals of the bulb. the glass polys on the outside need to point away from the center of the bulb, the normals of the inner sphere of the glass need to point into the center!
The humbucker of the guitar looks quite far in the back for my eyes, but maybe I'm wrong ;)

Phil
Posts: 154
Joined: Mon Nov 06, 2006 2:22 am
Location: St. Wendel, Germany

Re: Indigo Renderer 3.8.0 Beta Release

Post by Phil » Tue Mar 18, 2014 4:28 am

Hi,
It seems that 3.8 is much darker as 3.6.26
See picture, left is rendered with 3.6.26 and right is rendered with 3.8.
(camera tonemapping)

Best regards,
Philippe
Attachments
Tonemapping.png

User avatar
Zom-B
1st Place 100
Posts: 4682
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by Zom-B » Tue Mar 18, 2014 4:58 am

Phil wrote:Hi,
It seems that 3.8 is much darker as 3.6.26
See picture, left is rendered with 3.6.26 and right is rendered with 3.8.
(camera tonemapping)
Interesting,

What Exporter do you work with?

Can replace your object by a simple sphere and verify that this behavior, then upload the scene?

Post Reply
54 posts

Who is online

Users browsing this forum: No registered users and 1 guest