Indigo Renderer 3.8.0 Beta Release

General News and accouncements regarding the Indigo render engine
User avatar
drBouvierLeduc
Posts: 412
Joined: Wed Oct 11, 2006 2:32 am
Location: france

Re: Indigo Renderer 3.8.0 Beta Release

Post by drBouvierLeduc » Mon Feb 10, 2014 11:56 pm

On linux (ubuntu 13.10 x64), the interface is lacking all the icons, witch this message error in the console :

Code: Select all

libpng warning: Incompatible libpng version in application and library
libpng warning: Application was compiled with png.h from libpng-1.2.42
libpng warning: Application  is  running with png.c from libpng-1.4.3
indigo-3.8-iconless.jpg

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by OnoSendai » Tue Feb 11, 2014 5:54 am

Sroka8888 wrote:Good Work !

Problem: Online Material Database don't find any materials.
Fixed for next release, thanks for report.

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by OnoSendai » Tue Feb 11, 2014 7:01 am

Prof4D wrote:Does Not work for XP

The Point of the entry in procedure inet_pton is not found in library DLL WS2_32.dll.
Should be fixed for next release.

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by OnoSendai » Tue Feb 11, 2014 7:03 am

Patrice wrote:Curious bug with Indigo RT 3.8 (bidir, mlt ...)
Not on 3.6

Just a plan and a street lamp
Can send the simple test scene.
Yes, please do.

User avatar
Oscar J
1st Place Winner
Posts: 2170
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Indigo Renderer 3.8.0 Beta Release

Post by Oscar J » Thu Feb 13, 2014 8:52 am

Shadow rendering mode makes Indigo crash on Mavericks.

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Indigo Renderer 3.8.0 Beta Release

Post by FakeShamus » Sun Feb 16, 2014 2:03 am

ok, spoke too soon on my last edit. I am still getting crashes (segmentation fault) when trying to render in console mode on OSX 10.9, when Indigo attempts a save.

And then in normal GUI mode, rendering the same scene just gave me this crash after a few minutes render time:

Code: Select all

Process:         Indigo [3961]
Path:            /Applications/Indigo Renderer/Indigo.app/Contents/MacOS/Indigo
Identifier:      com.apple.IndigoRenderer
Version:         3.6 (244)
Code Type:       X86-64 (Native)
Parent Process:  launchd [199]
Responsible:     Indigo [3961]
User ID:         501

Date/Time:       2014-02-15 08:59:40.454 -0500
OS Version:      Mac OS X 10.9.1 (13B42)
Report Version:  11
Anonymous UUID:  3D654746-4BE0-49B7-A4C1-6F30DE992CE7

Sleep/Wake UUID: AD211865-05F0-48D0-A0CE-CE4F6E8DAB8A

Crashed Thread:  15

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000060fe001ef704

User avatar
Zom-B
1st Place 100
Posts: 4650
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by Zom-B » Sun Feb 16, 2014 2:17 am

FakeShamus wrote:

Code: Select all

...
Version:         3.6 (244)
...
Sure you are using version 3.8.0 here???
A clean install may help here.... or is the "internal version tag" just not correct for this Indigo build??

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Indigo Renderer 3.8.0 Beta Release

Post by FakeShamus » Sun Feb 16, 2014 3:18 am

yeah, this was with a clean install, actually.
version tag must not be updated

Rado Volmut
Posts: 11
Joined: Sat Feb 02, 2013 3:02 am

Re: Indigo Renderer 3.8.0 Beta Release

Post by Rado Volmut » Wed Feb 19, 2014 4:43 am

Hello,
speedup is great, but I have problem with slaves , after installing version 3.8 ( master and slaves too ), slaves can´t connect to master server.
Thanks

User avatar
Zom-B
1st Place 100
Posts: 4650
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by Zom-B » Wed Feb 19, 2014 8:59 am

Rado Volmut wrote:speedup is great, but I have problem with slaves , after installing version 3.8 ( master and slaves too ), slaves can´t connect to master server.
Win, OS, Linux?
No issues here on win 8.1 64bit, but my firewall needed new confirmation to allow the new EXE's connect via LAN!

Rado Volmut
Posts: 11
Joined: Sat Feb 02, 2013 3:02 am

Re: Indigo Renderer 3.8.0 Beta Release

Post by Rado Volmut » Wed Feb 19, 2014 9:38 am

Zom-B wrote:
Rado Volmut wrote:speedup is great, but I have problem with slaves , after installing version 3.8 ( master and slaves too ), slaves can´t connect to master server.
Win, OS, Linux?
No issues here on win 8.1 64bit, but my firewall needed new confirmation to allow the new EXE's connect via LAN!
We have Win7, when I was updating 3.6.x along a time wasnt needed fix firewall, but I will try it now.

Rado Volmut
Posts: 11
Joined: Sat Feb 02, 2013 3:02 am

Re: Indigo Renderer 3.8.0 Beta Release

Post by Rado Volmut » Wed Feb 19, 2014 11:30 pm

Rado Volmut wrote:
Zom-B wrote:
Rado Volmut wrote:speedup is great, but I have problem with slaves , after installing version 3.8 ( master and slaves too ), slaves can´t connect to master server.
Win, OS, Linux?
No issues here on win 8.1 64bit, but my firewall needed new confirmation to allow the new EXE's connect via LAN!
We have Win7, when I was updating 3.6.x along a time wasnt needed fix firewall, but I will try it now.
my slaves are still disable to connect to master. I shutdown whole firewall ( we have ESET ) on master computer and slaves too. it´s issue on the side of beta version 3.8 , or ?
thanks

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Indigo Renderer 3.8.0 Beta Release

Post by CTZn » Sun Feb 23, 2014 1:43 am

I'll bring this one at home, finally.

cheers

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Indigo Renderer 3.8.0 Beta Release

Post by FakeShamus » Sun Feb 23, 2014 7:49 am

doesn't sound like anybody else is having problems with this new version, but I continue to get crashes with errors such as this:

Code: Select all

Process:         Indigo [42837]
Path:            /Applications/Indigo Renderer/Indigo.app/Contents/MacOS/Indigo
Identifier:      com.apple.IndigoRenderer
Version:         3.6 (244)
Code Type:       X86-64 (Native)
Parent Process:  launchd [143]

Date/Time:       2014-02-22 14:45:02.260 -0500
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Interval Since Last Report:          347531 sec
Crashes Since Last Report:           6
Per-App Interval Since Last Report:  5445 sec
Per-App Crashes Since Last Report:   3
Anonymous UUID:                      89890EC5-DD1F-497B-9089-CF394F53D97B

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0xffffffff27d01dc4
Crashed Thread:  19
I thought it was maybe OSX 10.9 specific, but this time it's on 10.6
Indigo 3.6.26 does not seem to have these problems, so I'm feeling like it has to be something with this new build. any ideas about the instability here?

User avatar
Zom-B
1st Place 100
Posts: 4650
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.8.0 Beta Release

Post by Zom-B » Sun Feb 23, 2014 8:03 am

FakeShamus wrote:doesn't sound like anybody else is having problems with this new version, but I continue to get crashes with errors such as this...
Maybe a stupid question, but does this behavior happen to you also using the testscenes inside the Indigo folder, using their default settings?

If not, you maybe could pack your scene into a pigs and send it to the devs for debugging :)

Also test if this error with your scene is happening also with non BiDir render modes, since the 3.8 update has a lot of changes for BiDir...

Post Reply
54 posts

Who is online

Users browsing this forum: No registered users and 1 guest