Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

General News and accouncements regarding the Indigo render engine
Post Reply
15 posts • Page 1 of 1
User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by OnoSendai » Tue Nov 12, 2013 12:40 pm

Hi All,
This is a release candidate for 3.6 stable. This means that if there aren't any major bugs found in this build, this build will become the 3.6 stable build.

Please test!

Indigo for Windows 32-bit:
IndigoRenderer_3.6.26_Setup.exe

Indigo for Windows 64-bit:
IndigoRenderer_x64_3.6.26_Setup.exe

Indigo for Linux 32-bit:
IndigoRenderer_v3.6.26.tar.gz

Indigo for Linux 64-bit:
IndigoRenderer_x64_v3.6.26.tar.gz

Indigo for Mac OSX (10.6 - 10.8 ):
IndigoRenderer3.6.26.dmg


Indigo RT for Windows 32-bit:
IndigoRT_3.6.26_Setup.exe

Indigo RT for Windows 64-bit:
IndigoRT_x64_3.6.26_Setup.exe

Indigo RT for Linux 32-bit:
IndigoRT_v3.6.26.tar.gz

Indigo RT for Linux 64-bit:
IndigoRT_x64_v3.6.26.tar.gz

Indigo RT for Mac OSX (10.6 - 10.8 ):
IndigoRT3.6.26.dmg

Changelog:
3.6.26
* Updated bundled SkIndigo installer to 3.6.25.3.

User avatar
SaphireS
Indigo 100
Posts: 134
Joined: Tue May 05, 2009 9:06 am
Location: Austria
Contact:

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by SaphireS » Wed Nov 13, 2013 6:21 am

Great! Any hints on how you're planning to celebrate the release? ;)
Like a competition or something?

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by OnoSendai » Wed Nov 13, 2013 10:29 am

SaphireS wrote:Great! Any hints on how you're planning to celebrate the release? ;)
Like a competition or something?
A competition sounds like a good idea :)
Anyone have suggestions for a topic/theme?

User avatar
Juju
Posts: 270
Joined: Sat Mar 17, 2007 3:49 am
Location: South Africa

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by Juju » Wed Nov 13, 2013 11:24 pm

how about devising a method whereby the entrant should demonstrate as many of the new features as possible?

User avatar
fused
Developer
Posts: 3557
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by fused » Wed Nov 13, 2013 11:33 pm

Juju wrote:how about devising a method whereby the entrant should demonstrate as many of the new features as possible?
I quite like that idea :)

Tankin
Posts: 1
Joined: Sat Nov 16, 2013 8:02 pm

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by Tankin » Sat Nov 16, 2013 8:23 pm

So I installed 3.6.26 on my Windows7 master and Ubuntu 10.04 slaves and am now getting the following from my slaves:

Connected to master.
Connection Exception: Server doesn't accept protocol version, client protocol too old. (client protocol version: 12)
Connection to master terminated.

I probably need to update ubuntu or something but thought I should check here as well.

Thanks for any help.

Tankin
Posts: 1
Joined: Sat Nov 16, 2013 8:02 pm

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by Tankin » Mon Nov 18, 2013 3:00 pm

I also meant to mention that on the ubuntu slaves, indigo is listing its version as 3.6.12 in the GUI and at the top of the network slave

here's the whole bit from the slave (with ~)

Executing '-h 192.168.~.~ -n s'
Indigo Renderer v3.6.12, Linux 64-bit build.
Licence verified.
Licence type: Indigo 3.x Node.
Licensed to '~~~~'
Waiting for a master.
Attempting to connect to master at 192.168.~.~:7777...
Connected to master.
Connection Exception: Server doesn't accept protocol version, client protocol too new. (client protocol version: 12)
Connection to master terminated.

and repeats



(3.4.18 has been running without an issue)

Thanks again

User avatar
fused
Developer
Posts: 3557
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by fused » Tue Nov 19, 2013 2:14 am

Tankin wrote:I also meant to mention that on the ubuntu slaves, indigo is listing its version as 3.6.12 in the GUI and at the top of the network slave

here's the whole bit from the slave (with ~)

Executing '-h 192.168.~.~ -n s'
Indigo Renderer v3.6.12, Linux 64-bit build.
Licence verified.
Licence type: Indigo 3.x Node.
Licensed to '~~~~'
Waiting for a master.
Attempting to connect to master at 192.168.~.~:7777...
Connected to master.
Connection Exception: Server doesn't accept protocol version, client protocol too new. (client protocol version: 12)
Connection to master terminated.

and repeats



(3.4.18 has been running without an issue)

Thanks again
Hi Tankin,

3.6.12 is a little outdated. Did you download 3.6.25 and it shows as .12 nevertheless?
Ideally you would be running the same version on the master and slave computers.

Regards,
Yves

Tankin
Posts: 1
Joined: Sat Nov 16, 2013 8:02 pm

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by Tankin » Tue Nov 19, 2013 2:47 am

Yeah I downloaded the linux 64 package from the download page

http://www.indigorenderer.com/download-indigo-renderer

its saying 3.6.26 on the tar ball and extracted folder but says 3.6.12 as described when ran.

Tankin
Posts: 1
Joined: Sat Nov 16, 2013 8:02 pm

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by Tankin » Tue Nov 19, 2013 2:49 am

Should I try 3.6.25?

User avatar
fused
Developer
Posts: 3557
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by fused » Tue Nov 19, 2013 3:13 am

Tankin wrote:Should I try 3.6.25?
Sorry, that was a typo. I meant 3.6.26.

Seems like there is some problem with out linux distribution then. I will look into this right now.

User avatar
fused
Developer
Posts: 3557
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by fused » Tue Nov 19, 2013 4:39 am

fused wrote:Sorry, that was a typo. I meant 3.6.26.

Seems like there is some problem with out linux distribution then. I will look into this right now.
Hi Tankin,

I couldn't find any problems with the Indigo 3.6.26 linux distribution so far.

Can you try this:

Code: Select all


> cd ~/Downloads
> wget http://downloads.indigorenderer.com/dist/beta/IndigoRenderer_x64_v3.6.26.tar.gz
> tar -zvxf IndigoRenderer_x64_v3.6.26.tar.gz
> cd IndigoRenderer_x64_v3.6.26
> ./indigo_console -v

This should download and unpack Indigo Renderer and then print the version.

To test-run the network slave (in the same directory):

Code: Select all

> ./indigo -n s
Let me know how this goes for you.

Regards,
Yves

Tankin
Posts: 1
Joined: Sat Nov 16, 2013 8:02 pm

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by Tankin » Tue Nov 19, 2013 4:43 am

I'll test this later tonight and get back to you.

Thanks for the help.

Tankin
Posts: 1
Joined: Sat Nov 16, 2013 8:02 pm

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by Tankin » Wed Nov 20, 2013 5:42 am

So "-v" is sending out the version fine on the corrupt install in console mode but brings up the gui with version 3.6.12 displayed when ran non-console

I re-downloaded the package and tried a run in a fresh folder, as suggested, with the same results.

I did not download the tar.gz directly thru ubuntu onto the slave as I need to get a replacement wireless card, so it is possible Windows is corrupting the tarball.

I was able to get the network slaves running without a hiccup in console mode and they are plugging away right now, but anytime that I use the non-console indigo I seem to be stuck in 3.6.12

LukeAD
Posts: 1
Joined: Tue Apr 01, 2014 8:10 am

Re: Indigo Renderer 3.6.26 - 3.6 Stable Release Candidate

Post by LukeAD » Tue Apr 01, 2014 9:58 am

Getting this error message when loading SketchUp Pro 2014 after installing 3.6.26 version. Any ideas?

Error Loading File C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb
Error: #<SyntaxError: C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/ObjectEditor.rb:261: syntax error, unexpected ':', expecting keyword_then or ',' or ';' or '\n'
when Sketchup::ComponentInstance:

^
C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/ObjectEditor.rb:263: syntax error, unexpected keyword_when, expecting keyword_end
when Sketchup::Group:

^
C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/ObjectEditor.rb:263: syntax error, unexpected ':'
when Sketchup::Group:

^
C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/ObjectEditor.rb:349: syntax error, unexpected keyword_end, expecting end-of-input
end #class

^>
C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb:12:in `load'
C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo/skindigo_core.rb:12:in `<top (required)>'
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/extensions.rb:197:in `require'
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/extensions.rb:197:in `load'
C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo.rb:19:in `register_extension'
C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo.rb:19:in `<module:SkIndigo>'
C:/Users/lukead/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/skindigo.rb:4:in `<top (required)>'

Post Reply
15 posts • Page 1 of 1

Who is online

Users browsing this forum: Ahrefs [Bot] and 2 guests