Indigo Renderer 3.4.4

General News and accouncements regarding the Indigo render engine
Voytech
Posts: 236
Joined: Thu Oct 06, 2011 8:57 am

Re: Indigo Renderer 3.4.4

Post by Voytech » Fri Aug 03, 2012 11:48 pm

Headroom wrote:
Oscar J wrote:
FakeShamus wrote:Good Stuff! Orthographic camera is very exciting!

Couple peeves as a Mac user:
Command-Q still reloads the scene, instead of quitting the application.
And we are still missing the "File > Save Material" menu for saving materials from an open scene (apparently this shows up in the property editor pane for Windows users - but we don't get it in OSX).

thanks!
+1. Don't neglect us mac users!
+ 1 to that ;-)
+1
It's very annoying.

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Re: Indigo Renderer 3.4.4

Post by suvakas » Sat Aug 11, 2012 12:58 am

If I put sun and sky to separate layers, then sky renders black on final image.
Anyone else has this issue?

User avatar
solarray
1st Place Winner
Posts: 110
Joined: Mon Apr 20, 2009 3:22 am
Contact:

Re: Indigo Renderer 3.4.4

Post by solarray » Sat Aug 11, 2012 8:07 pm

suvakas wrote:If I put sun and sky to separate layers, then sky renders black on final image.
Anyone else has this issue?
Here it works.

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Re: Indigo Renderer 3.4.4

Post by suvakas » Sat Aug 11, 2012 10:17 pm

Sky seems to work ok here too now. Don't know why it didn't work the other day.

One thing that does not work is:
<save_images_on_close>

Could you guys please fix this?

steven369
Posts: 10
Joined: Mon May 10, 2010 9:22 pm

Re: Indigo Renderer 3.4.4

Post by steven369 » Mon Aug 13, 2012 1:52 am

Hi Suvakas,

the other day, my 3.2 Version did the same. I found GPU-Mode and
eventually toggling Glass-acceleration to be the problem - Don't know
nothing about the technics, but maybe it helps!

Cheers

Stephan
suvakas wrote:Sky seems to work ok here too now. Don't know why it didn't work the other day.

One thing that does not work is:
<save_images_on_close>

Could you guys please fix this?

User avatar
fused
Developer
Posts: 3558
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo Renderer 3.4.4

Post by fused » Mon Aug 13, 2012 10:08 pm

suvakas wrote:Sky seems to work ok here too now. Don't know why it didn't work the other day.

One thing that does not work is:
<save_images_on_close>

Could you guys please fix this?
Hey Suv,

Everytime I test it it seems to work.

Can you provide a scene and steps to reproduce?

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Re: Indigo Renderer 3.4.4

Post by suvakas » Tue Aug 14, 2012 8:17 am

Hey Yves,
Here's a scene. Turn off any light layer(s) and close Indigo.
Changes are not saved to png.
Basically all the changes you make to light layers get dismissed.
Attachments
save_on_close_bug.pigs
(25.23 KiB) Downloaded 216 times

Xaon
Posts: 25
Joined: Wed Jun 02, 2010 12:05 am

Re: Indigo Renderer 3.4.4

Post by Xaon » Tue Aug 14, 2012 8:20 pm

J'ai un soucis lors de l'ouverture d'Indigo :
indigo_erreur.jpg
Je n'avais pas ce problème en version précédente...

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Indigo Renderer 3.4.4

Post by CTZn » Tue Aug 14, 2012 11:48 pm

Xaon wrote:J'ai un soucis lors de l'ouverture d'Indigo :
indigo_erreur.jpg
Je n'avais pas ce problème en version précédente...
- Quelle version d'Indigo utilisait-tu précédemment ?

- As-tu installé une autre application dans l'intervalle ?

Attends, je vais demander confirmation ici mais d'autres semblent avoir trouvé une solution générique.

Vois ce topic si tu utilise Windows Vista (et aussi dans certains cas pour seven), il semblerait qu'il faille cette mise à jour.

Plus de résultats Google: https://www.google.fr/search?q=%22confi ... utf-8&aq=t

Le lien de la MAJ:
http://www.microsoft.com/fr-fr/download ... px?id=5638

Question to the Glare team: The issue that Xaon is bumping into might be linked to an outdated redistributable, however it didn't happen with the Indigo version he was previously using (I've asked him wich). Does it make sense to proceed to the linked update ? Did I pin the issue down already ?

Xaon
Posts: 25
Joined: Wed Jun 02, 2010 12:05 am

Re: Indigo Renderer 3.4.4

Post by Xaon » Wed Aug 15, 2012 7:44 pm

CTZn wrote: - Quelle version d'Indigo utilisait-tu précédemment ?

- As-tu installé une autre application dans l'intervalle ?
J'utilisais la version 4.3.0 précédemment. J'ai installé la mise à jour de ton lien et redémarré mon PC mais toujours le même problème. Je n'ai pas installé d'autres applications entre temps.

User avatar
SmartDen
Developer
Posts: 999
Joined: Fri Oct 13, 2006 10:58 pm
Location: Canary Islands
Contact:

Re: Indigo Renderer 3.4.4

Post by SmartDen » Wed Aug 15, 2012 7:47 pm

Linux 32 GUI Build still crash on my computer. I suppose it is becouse i don't have supported video card or my card don't supports CUDA/OpenGL.

User avatar
fused
Developer
Posts: 3558
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo Renderer 3.4.4

Post by fused » Wed Aug 15, 2012 9:07 pm

SmartDen wrote:Linux 32 GUI Build still crash on my computer. I suppose it is becouse i don't have supported video card or my card don't supports CUDA/OpenGL.
Hey Denis,

could we get some more info? When you run the Indigo ui from the terminal, does it print an error? Which distribution are you using? What graphics hardware do you have?

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Indigo Renderer 3.4.4

Post by CTZn » Wed Aug 15, 2012 11:48 pm

Xaon wrote:
CTZn wrote: - Quelle version d'Indigo utilisait-tu précédemment ?

- As-tu installé une autre application dans l'intervalle ?
J'utilisais la version 4.3.0 précédemment. J'ai installé la mise à jour de ton lien et redémarré mon PC mais toujours le même problème. Je n'ai pas installé d'autres applications entre temps.
You've got a new private message.

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Indigo Renderer 3.4.4

Post by StompinTom » Sun Aug 19, 2012 4:11 am

Setting a precedence of 1 for Transparent Specular materials makes a black image:

EDIT: Precedence of 2 works just fine...
Attachments
precedence_10.jpg
Precedence: 10
EV +0
precedence_1.jpg
Precedence: 1
EV +10

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Indigo Renderer 3.4.4

Post by StompinTom » Sun Aug 19, 2012 4:22 am

Also:

- Make cube around scene with Transparent Specular material, no absorption, IOR 1.0, Uniform scattering of about 0.01.
- Start Indigo.
- Select the fog medium, change Scattering from None to Shader, type in something (def eval(vec3 pos) vec3 :
vec3(fbm(pos * 1.0, 3) * 10.0))
- Rendering won't start (SPS and SPP stay at 0)
- Disable Shader or set back to None (for Scattering)
- Rendering still won't start, Indigo sometimes locks up

Seems there's a problem with using Shaders with scattering media? Just seems to hang...

EDIT: Maybe it works after a very long time. Seems to go extremely slowly after a long warmup.

Post Reply
59 posts

Who is online

Users browsing this forum: No registered users and 1 guest