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Overview

This manual covers the installation and usage of Cindigo, the Cinema 4D 

exporter for Indigo Renderer. The information in this manual will allow you to 

understand and use Cindigo proficiently.

About exporters

Indigo is independent of a modelling package and uses its own file format, 

called an Indigo Scene File (.igs). Before Indigo can render your scene, it 

must be converted into an .igs file. The job of an exporter is to create an .igs 

file from your currently open scene. Cindigo is such an exporter.

Acknowledgements
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Installing Cindigo 2.2

Step 1. Check your version of Cinema 4D

Cindigo is compatible with release 10 to 11.5 of Cinema 4D. There is a Mac 

version of Cindigo available for release 10.5 to 11.5. There are 64-bit 

versions of Cindigo available. 

Step 2. Download and install Indigo

Download Indigo for your system and install it to the default location. 

Instructions for doing this are in the Indigo Manual.  You can download Indigo 

from:

http://www.indigorenderer.com/download/  

Step 3. Download and install Cindigo 2.2

Download the version of Cindigo for your system from:

http://www.indigorenderer.com/cinema4d  

Cindigo comes with an installer for Windows and Mac. Both installers will look 

for a “plugins” directory in all known locations for Cinema 4D.

Cindigo expects to find Cinema 4D at these locations:

Windows c:\Program Files (x86)\MAXON\Cinema 4D RXX

or

c:\Program Files\MAXON\Cinema 4D RXX

Mac /Applications/MAXON/Cinema 4D

If you have any issues installing Cindigo, please email us at 

support@indigorender.com.
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Restart Cinema 4D after installing Cindigo and you should see see Cindigo 

2.2 become available under the Plugins menu.

The Cindigo plugins menu

You are now ready to use Cindigo.
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Things to know

There are several concepts you need to know to know to fully understand 

how Indigo works and how Blendigo treats these concepts. Refer to the 

Indigo manual and the Techniques Manual for more detailed information.

Indigo is physically based

Indigo is a physically based renderer, that means that if is possible to 

construct a photo in the real world, it is possible to render it in Indigo. 

Blendigo has the job of converting the virtual world of Blender into the real 

world representation used by Indigo. 

Users with experience of studio photography may find setting up a scene in 

Indigo a familiar experience.

Units of measurement

Indigo works on units of metres. Blendigo by default converts on Blender unit 

of distance to one metre in real world space. Select an object and press n to 

see the position of the object in blender units to get an idea of the scale of 

your scene. Because Indigo is a physically-based renderer, it is important that 

the scale is correct.

Light sources

Blender has some  light-sources that do not exist in the real-world – for 

example point lights (lights that are infinitesimally small and exceptionally 

bright) and 'invisible spotlights'. To use Indigo correctly you will need to 

master 'emitting materials' to create realistic lights in your scenes.
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Realistic Materials

Because Indigo is a photo-realistic renderer, the material properties of objects 

must be of a higher detail to accurately simulate them. This not only means 

higher resolution textures, but also correctly set material types that describe 

things about the material, such as transparency, roughness of the surface, 

and how light moves through the object.
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The Plugins Menu

The Plugins Menu is mainly used to create Indigo objects, convert materials 

and start rendering.

Render with Indigo

This exports the current scene to be rendered with Indigo.  This works 

identically to the Cinema 4D Render > Render View command, except it 

exports using Indigo materials and launches Indigo to render the scene.

Import Material .igm/.pigm

This loads an .igm (Indigo Material) or .pigm (Packed Indigo Material) file 

from your computer and adds it to your scene so it can be applied to an 

object.

Convert Materials

This will load all of the Cinema 4D materials and convert them automatically 

to Indigo materials. Cindigo will convert all C4D materials automatically on 

export to Indigo, however using this function will give you more control over 

the material settings.
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Indigo Instance

Creates an instance that can be used to make multiple copies of an object in 

a memory-efficient and CPU-efficient way. Indigo instances are faster to 

render than Cinema 4D instances (which aren't real instances but are copies).

Bake Material on Object

Cindigo bakes all C4D shaders to textures on export, but this feature allows 

you to bake unique 3D shaders to an objects UV map. It works similar to 

C4Ds "bake on object" command. A decent UV map is required. To use this 

function follow these steps:

Select the texture tag of a polygon object that has an Indigo material 

applied. Click Plugins > Cindigo 2.2 > Bake Material on Object.

Bake Material on Object dialog box

Select the channels you want to bake and specify an output path. Pixel 

Border adds a blank border to the output texture file. Super Sample is an 

anti-aliasing technique.
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Generate UVW Tag

C4D does not fully support UVW map generation for custom materials. This 

Cindigo function allows you to bypass this limitation. Just select a texture tag 

with an Indigo material applied and click Plugins > Cindigo 2.2 > 

Generate UVW Tag.
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Indigo Render Settings

The Indigo Render Settings let you control various aspects of how Indigo will 

render the scene. 

Cindigo Render settings

Most of the settings used for your renders will be copied directly from the 

existing Cinema 4D render settings, e.g. width and height come from the 

Output section of the Render Settings dialogue. However, there are some 

Indigo specific render settings that can be accessed via:

Render menu > Render settings > Effect... > Indigo Render Settings

Note that you need to press the “Effect...” button on the Render Settings 

window to access the advanced Indigo Settings. You do not need any other 

render pass, Indigo does it all.
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Export settings

Custom export path: Sets a path for your scene to save at when exported 

to Indigo for render. 

Export to scene dir: Exports to the set Cinema4D save path.

Custom image save path: Indigo automatically saves an image from the 

rendering scene at set intervals to this, or default, location.

Save to scene export path: Sets image save path to export path specified 

above.

Render Options

Clay render: This exports the scene with all the materials replaced with a 

clay material with a color specified from the Clay color picker. This can be 

used to get a quick 'draft-view' of the scene.

Clay render off Clay render on

Low priority: Sets the Indigo Renderer programs process priority. Set this to 

allow Indigo to render in the background without a system slow-down.

Background alpha: Renders an alpha layer based on visible objects and 

background.

Console mode: Starts Indigo in a command line window.

Export animation: Exports all frames of an animation and spends a certain 

amount of time on each frame based on the halt settings in the render 

settings tab.
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Network Options

Start as master: Automatically starts Indigo in Network rendering mode 

through the port specified adjacent. See Indigo Manual for more information 

on network rendering.

Environment

Cindigo environment render settings with Sun light type selected

Scene scale: The scale that Cindigo converts Cinema4D's units to real-world 

units. Because Indigo measures things in meters, you may want to change 

this if you have modelled your scene in a different scale. Default is meters.

Light type: These settings control the background of your scene. They all 

contribute a certain amount of light to the scene.
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Sun

Use Indigo's Sun & Sky model. Create a directional object to use for the 

Sun Direction, such as an infinite light and drag the object's tag into this 

dialog box. The direction of this object will now aim the sun, which changes 

the light direction and color depending on the angle for sunset/sunrise 

effects.

Turbidity: Controls the 'haziness' air. A lower value will make the sky bluer 

and clearer, and a high value will make it greyer.

Extra Atmospheric: Renders with only the sun, and not the sky. Good for 

renders of outer-space.

Separate Sun/Sky layers: Puts the sun and sky into separate light layers.
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Background

Plain material

Use a material as background. Supports HDR environment maps in EXR or 

FLOAT formats. Requires material to have emission enabled.

HDR Environment map

None

 A plain black background.
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Render Settings

General render settings.

Render Mode: If you are not sure which to use, PathTracing with BiDir is 

recommended.

Hybrid Mode: Not currently supported.

Auto Choose Num Threads: Automatically chooses all available CPU cores 

for rendering. Turn this off to specify number of threads to use for rendering.
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Halting, intervals, etc

Halt-time: Number of seconds to keep rendering for. Indigo will stop 

rendering and wait for the user to save the image after this amount of time.

Halt samples per pixel: Indigo will keep rendering until the specified 

number of samples per pixel is reached. The correct spp value differs for each 

image but a value of 200 spp is suitable for many simpler scenes.

Image save period: Time (in seconds) that Indigo will automatically save 

an image from the current rendering process. Used as a backup feature in 

case of a crash or system failure. 

Output Settings

Save untonemapped .exr: Save image as a raw HDR image without 

tonemapped adjustments.

Save tonemapped .exr: Save tonemap-adjusted HDR image. 

Save to .igi: Saves an IGI file for reach rendered scene. On by default.

Cache trees: Saves caches of the scene acceleration structure. Makes 

reloading scenes faster. On by default.

Logging: Keeps a log of rendering process. Used for debugging purposes.

Advanced Settings

These settings should not usually be changed.
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Light Layer Names

Name light layers for reference both in Cinema4D and the Indigo Renderer. 

You can set light layers in the Material Attributes and in the Indigo Light Tag.

Light layer names tab of the render settings
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Material Settings

Here you can edit the attributes of an Indigo material. It can be found by 

selecting an Indigo material and looking in the Attribute Manager, or double-

clicking on the Indigo material.

The Cindigo material editor

To create a new Indigo material, navigate Material Manager > File > New 

Indigo Material. 

Create new Indigo material
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Render Preview 

This function will use Indigo to create a small preview of the current material 

settings. Note that currently you will have to close the Indigo_console.exe 

program to stop rendering this preview.

Beneath the preview box you can give a name to the material, and add it to a 

Cinema4D layer.

Material Types

Here is a brief description of Indigo material types and attributes. Select the 

desired material type from this drop-down. See the Indigo manual for 

detailed descriptions of material functions and attributes.

Material type drop-down

Diffuse: Diffuse materials are flat, matte 

surfaces that don't have shiny edges. Flat 

wall paint, or a piece of paper are good 

examples of a diffuse material. There will be 

no particular reflection from a diffuse 

material.

Oren Nayar: Oren-Nayar materials are 

very rough materials that scatter light in 

every direction. They are rougher than 

diffuse materials. Oren-Nayar is useful for 

creating surfaces that are like clay, or 

generally rough. They aren't shiny at all. 
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Phong: Phong is a shiny material. 

Commonly used for shiny paints or any 

metals. In particular, phong will have a 

"specular highlight" where the light is 

completely reflected. Phong is useful for 

anything that has a lacquer applied to it - for 

example a shiny wood floor or a car paint.

Transmitter: A diffuse transmitter. Adds 

translucency to a material for allowing light 

to pass through. Used to simulate lamp 

shades or paper.

Specular: Specular materials are quite 

powerful and can be made to act as perfect 

reflectors (like a mirror) or as a fully 

transparent glass and anything in between.

Glossy: Glossy Transparent. Gives a rough 

surface to a transparent material. Can be 

used for frosted glass.

Blend Material: The is a material type that 

lets you create compound materials that are 

a combination of other materials. Blended 

materials have a 'blend map' that specifies 

how to blend the two sub-materials 

together. For example, you might have a 

shiny phong material combined with a rusty 

diffuse material. The blend map would show 

where the rust spots show through.
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Null Material: The null material is only really useful for debugging your 

scenes, as it does not interact with light in any way. Can be used to change 

the opacity of a material.

Material Channels and attributes

Check desired channels from list to be used for the material.

Default settings for material type Diffuse

Selecting different material types will change the list of options below, some 

material types share the same channels as others. Here is a list of all material 

channels for all material types.

Transparent: Allows light to pass through the material.

Internal medium: Controls how light moves through the interior of a mesh.

Color: The color of the surface including 

textures.

Sigma: Defines the roughness of the 

surface.
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Phong: The amount of light reflected. NK 

data is data from lab-measured metals.

Exponent: Controls the 'roughness' of the 

surface. The smoother the surface (or 

higher the IOR) the sharper the reflection.

Absorption layer: Absorbs light other than 

the color specified.

Bump: Add a bump map. Does not displace 

the surface, just gives the illusion of a 

bumped surface.

Displacement: Add a displacement map. 

Displaces the surface of the object with the 

material applied.

Emission: Emits light from the mesh 

surface. Used for all types of lights. Adjust 

parameters to change light color brightness.
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Blend: Add a material here to mix with the 

current material. If no material is defined, 

the default is mixed with a null material. 

Extra Options: 

Texture Preview Size: This changes the quality of the texture in the 

Cinema4D view-port, it does not affect the rendered scene at all.

Shader Baking resolution: The resolution to bake a shader at on export.

Export Material: Export the material to be used externally.

Assignment: Any objects that have this material applied are listed here.
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Cindigo Tags

There are several special Cindigo tags you can add to you Cinema4D objects. 

These tags extend the functionality of certain Cinema4D objects to include 

Indigo-specific functions. See the Indigo manual for more information.

Cindigo Tags

You can access this menu via:

Object Manager menu > Tags > Cindigo 2.2 Tags

Indigo Camera Tag

Add this to a Cinema4D camera object to set Indigo specific settings. Use in 

conjunction with the Cinema4D's camera settings such as focal length and 

aperture. 

The Camera Tag's attribute editor
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White Point: Adjust the White Point to get rid of colored tinges to an image. 

Can be changed during or after rendering in the Indigo Renderer.

F-Stop: Adjusts the size of the aperture of the Indigo Camera. Larger radius 

means more depth of field. 

Depth of field effect obtained by changing the f-stop

Exposure Duration: How long the exposure will be.  The longer the 

exposure duration, the greater the light energy registered by the sensor.

Autofocus:  Sets the focal distance to the distance from the camera straight 

forward to the first object it sees.

Aperture Diffraction: Aperture diffraction allows the simulation of light 

diffraction through the camera aperture. Such diffraction creates a distinct 

'glare' effect around bright light sources in the image.

Use Obstacle Map:  An obstacle map texture is used when calculating the 

diffraction though the camera aperture. Use to change the way the aperture 

diffraction appears.

Aperture Shape:  This allows a particular shape of camera aperture to be 

specified. 

Generated Aperture: Use the following controls to change the shape of the 

aperture: Num Blades, Blade Offset, Blade Curvate. Radius, Start 

Angle
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Indigo Exit portal Tag 

Turns an object into an exit portal. Exit portals are useful for speeding up 

interior renderings, when the interior is lit by an environmental light source, 

such as the sun/sky model.

1. If exit portals are present in the scene, then all openings must be 

covered by exit portals. 

2. The portal normals must face inwards to the scene.

Indigo Light Tag

Add this tag to the lights Omni lights, Area lights, or Spot lights to set Indigo 

specific light options. The options are the same as adding emissions to a 

material. Because there are no point lights in Indigo, on export these special 

Cinema4D entities are translated into a mesh and act exactly as if you made 

a light bulb mesh and applied an emitting material to it.

Indigo Subdivision Tag

Divides each triangle in the mesh into 4, with each level increasing it 

exponentially. Therefore a large mesh mesh of, say, 1 million becomes 4 

million subdivided only once. Twice it becomes 16 million, and three times 

become 64 million.
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Tutorial

This is a quick tutorial to get you familiar with Cindigo. A basic understanding 

of Cinema4D is required. The tutorial file is included with the download.

1. After installing Indigo and Cindigo, open up Cinema4D and construct a 

simple scene. This has a window for light to shine in, and two balls to 

test materials on.

2. Render it with Indigo by Plugins > Cindigo 2.2 > Render with 

Indigo. Notice it is very plain and noisy, there is no need to render it 

for more than a few seconds as you can see right away that it needs 

work.

Quick render with Indigo
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3. Firstly we will light it with the sun and sky model, which is the easiest 

and quickest way to add light. Add a C4D Infinite Light and point it in 

the direction that you want the sun to face.

The sun will come in through the window

4. Open up the Render Settings, and add Indigo to the list by clicking 

Effect > Indigo Render Settings. Go to the Environment tab and 

click-and-drag your Infinite Light tag into the Sun Direction.

Depending on how large you have made your scene, you may want to 

change the scene scale to cm as well.
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5. Render again to see the effect of real lighting on the scene.

6. Now to add some materials to the scene. Add a new material by 

clicking: Material Manager > File > New Indigo Material. 

Make a Phong material with a huge Exponent around 100,000 and 

crank the IOR up to 100.

Drag the new material on to the two balls.

Also make a nice material for the walls and put it on them too.

7. Another render shows what they look like.
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8. Lastly, we will add a light bulb for some interior lighting. Create 

another sphere, smaller and above the other two. Create a new Indigo 

Material and turn Emissions on. Make it Blackbody with a 

temperature of 3500, and put the gain down at 0.001. Drag this 

material onto the new sphere to create a light and render again.

If the light is too bright, the Reinhard Tonemapping will compensate 

for it and make the sun & sky dark, which is why the gain has been 

put to 0.001.
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Going Further

You are now ready to start exploring Cinema 4D and Indigo. To learn more 

about using Indigo, see these resources.

The Indigo website:

http://www.indigorenderer.com/  

The Indigo materials database:

http://www.indigorenderer.com/materials/  

The Indigo forums are a lively place of debate - you should especially take a 

look at the Cinema 4D sub-forum.

http://www.indigorenderer.com/forums/  

If you need support, please email:

support@indiorenderer.com  

We hope you enjoy using Indigo and look forward to seeing your renders!
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