Download Trial Buy now
Log in or Sign up for the chat.

Search  | Login  | Register

Post new topic Reply to topic  [ 12 posts ] 
Offline
User avatar
Hello,

I have just created a LatLong HDR image. I made this quick render and noticed that the backgroung image is scaled in the vertical direction :

Image

This EXR is 6694x1595px, 72dpi. It is not a real 360° panorama, but I guess that has nothing to do with the current issue.

Skindigo 1.1.5 + Indigo 1.1.5

Within Skindigo render settings :

- Output 800x800
- Camera : default settings except f/2.8
- Environment : x Env. map - Type Lat/Loong - Gain 1000

Should the EXR image have a specific length/height ratio ?

Thanks for your help :wink:

PS : if anyone is interested in the exr file, I will share it with pleasure (not the greatest HDR though !)


 Profile  
 
Offline
I've noticed this with exr's also. I have tried many times to use them like this but with no luck. I don't think there is the ability in Skindigo (or maybe indigo) to size and arrange the exr image. I wish there were!


any word on this Whaat?


 Profile  
 
Offline
User avatar
Developer
eulgrand wrote:
Should the EXR image have a specific length/height ratio ?

I think that is the issue here....but I'm not 100% sure.


 Profile  
 
Offline
User avatar
most of the EXR files i have are all 2:1 in width to height, yours is nearly 4:1 ... maybe thats why?


 Profile  
 
Offline
I've resized exr images outside of sketchup and brought them back in and it seemed like it didn't make a difference. perhaps there is a single size they all need to be, but with mine they always are way huge in the render. like Indigo scales them up or something.


 Profile  
 
Offline
The fact that you've got a 4:1 aspect ratio is the problem. Even if you rescaled this to 2:1, you distorted the image in the process.

Add black bars at the top and bottom to bring the proportions to 2:1. Alternatively, crop the image to a 2:1 aspect ratio.

When mapping an image to a sphere using spherical mapping, you cover 360 degrees in the x direction and 180 degrees in the y direction -- hence the 2:1 aspect ratio requirement.


 Profile  
 
Offline
User avatar
Thank you all for your feedback.

v_mulligan, I now understand why some lat/long HDR's that can be found on the internet have those black bars at the bottom.

:wink:


 Profile  
 
Offline
User avatar
Site Admin
If it's not a 360 degree panorama, then I don't think it will work correctly.


 Profile  
 
Offline
OnoSendai wrote:
If it's not a 360 degree panorama, then I don't think it will work correctly.


True. Neither the cropping nor the black bar method is entirely satisfactory. The former will leave seams which may appear in reflections. The latter will, of course, leave the black bars, which won't cast light properly and will also appear in reflections.


 Profile  
 
Offline
User avatar
Indigo 100
Hi!

Thanks for these useful pieces of information.
I'm a total beginner in terms of environment maps.
:mrgreen:

I've got the following problem:
I'm trying to use a "clear sky" environment map (.exr file) but it's way too bright if I use the default settings.

I'm using Skindigo.
I modelled a room with 3 wide windows, so that light can come into the room profusely and light up the room.
(sorry I'm at work, I have no picture to attach)

I've tried several things, like:
- lowering the env map Gain down to 1 (!)
- lowering camera ISO down to 1 (!!!)
- lowering the camera "ev adjust" down to -10 or -15 (!!!!!!!)

But it still is very bright compared with the room.
When the settings are very low (like above) I get a very dark room, and a very "dull" env map in the background.

Any idea about the settings I should use?

Many thanks for your replies, I'm really stuck at the moment...
:(

_________________
Visit my website!
http://www.fairview-3d.com Studio 3D


 Profile  
 
Offline
Indigo 100
Yeah, if your EXR only covers the sky, then enlarge your canvas in Photoshop x2 while keeping the sky on top. You should just have a big black bar that covers the bottom half of your image, where the ground and everything below the horizon should be.

About the lighting, it makes sense that the sky outside will be overexposed if you're going to have a bright interior. Keep in mind that the light has to come in only through a couple windows, so it has to be much brighter than it would be outside. Taking a picture of the inside of your house with a camera will illustrate this: your exterior will be blown out, or your interior will be underexposed.

_________________
--

http://www.tomsvilans.com
http://www.tomsvilans.com/blog


 Profile  
 
Offline
User avatar
Indigo 100
Thanks StompinTom for these useful pieces of information, and for the PhotoShop tip : it should work now, many many thanks!!!
:D

_________________
Visit my website!
http://www.fairview-3d.com Studio 3D


 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group