Download Trial Buy now

Search  | Login  | Register

Post new topic Reply to topic  [ 7 posts ] 
Offline
User avatar
Hi All,

I've just upgraded to v3 of Indigo and it's a huge improvement - love it!

However, I'm having a problem with external OBJ files. In Indigo v2 I had a scene set up which had several trees referenced in and it worked really well. Now, when using v3 and after using the 'Edit Active Mesh' referencing in SkIndigo, the trees won't show up! The trees are in the OpenGL preview (and to scale), but not in the rendered scene.

I tried a test scene and noticed something a bit strange. When referencing one tree in with basic colours for the bark and leaves the external OBJ shows up. However, if I apply a texture to it then those elements of the tree disappear.

Attachment:
Tree.png
Tree.png [ 214.68 KiB | Viewed 819 times ]


The above render has just plain colours assigned for the bark and leaves. I have a test swatch beneath the tree also

Attachment:
Tree2.png
Tree2.png [ 203.01 KiB | Viewed 819 times ]


This one has the leaf colour replaced by a leaf texture and it disappears!! The swatch has also gone.

Am I missing something crucial? I thought I'd followed all the steps right! :-p Please help!

Thanks,

Jen

_________________
Architect in training...
...almost done!


 Profile  
 
Offline
User avatar
Just to update... I looked at the textures a little further and realised they were TIF files.
After changing them to PNGs the render worked!! Have TIFs been disabled in the new release of Indigo?

Thanks,

Jen


Attachments:
Tree3.png
Tree3.png [ 237.9 KiB | Viewed 810 times ]

_________________
Architect in training...
...almost done!
 Profile  
 
Offline
User avatar
Developer
Hi,

Did you adjust the color of the TIF texture in SketchUp? I think this can create problems.

Try resetting the color to the original texture color and see if the TIF versions works.

_________________
Follow SkIndigo on Facebook


 Profile  
 
Offline
User avatar
Whaat wrote:
Hi,

Did you adjust the color of the TIF texture in SketchUp? I think this can create problems.

Try resetting the color to the original texture color and see if the TIF versions works.


Hi Whaat,

Yep, that appears to have been the problem. Thanks! :-) I presume there's something sketchup does to the TIF file that makes it un-usable?

_________________
Architect in training...
...almost done!


 Profile  
 
Offline
User avatar
Developer
gjengi wrote:
Whaat wrote:
Hi,

Did you adjust the color of the TIF texture in SketchUp? I think this can create problems.

Try resetting the color to the original texture color and see if the TIF versions works.


Hi Whaat,

Yep, that appears to have been the problem. Thanks! :-) I presume there's something sketchup does to the TIF file that makes it un-usable?

Yeah, I think SketchUp does something to the texture that Indigo does not like. However, I need to look into this a bit more to confirm the issue.

You can still use Photoshop to color change the texture and then use external textures instead.

_________________
Follow SkIndigo on Facebook


 Profile  
 
Offline
User avatar
Site Admin
Hi Jen,
Can you please send me the tree model and textures if possible? (nick@indigorenderer.com)

Thanks!


 Profile  
 
Offline
User avatar
Whaat wrote:
Yeah, I think SketchUp does something to the texture that Indigo does not like. However, I need to look into this a bit more to confirm the issue.

You can still use Photoshop to color change the texture and then use external textures instead.


Thanks Whaat,

On an unrelated note, whenever I add a 'fake' sun to environment maps the environment map goes black - is there a setting I'm missing? I've tried different tonemapping and different environment maps but nothing seems to work.

OnoSendai wrote:
Hi Jen,
Can you please send me the tree model and textures if possible? (nick@indigorenderer.com)

Thanks!


Just sent it.

Jen

_________________
Architect in training...
...almost done!


 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group