Download Trial Buy now

Search  | Login  | Register

Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3  Next
Offline
User avatar
Developer
PureSpider wrote:
To better imagine it: it works just like C4D's own infinite light 8)

indeed!


 Profile  
 
Offline
Got it!!!!
Thanks works insanely great.


 Profile  
 
Offline
fused wrote:
a.manca wrote:
A curiosity: how do you make the mac version?I imagine that the code is the same in both versions...(windows and mac versions)...So, if I know the code of the windows version can I compile it and make a .dylib ?


Basically, yes :)


Thanks fused. Exscuse me! I saw your answer in this moment...so I have Xcode (because I want to program for iphone) and I can compile a .dylib using Xcode. But I don't know how to do that :( And I don't know how to know the code of the plugin for windows! How do you do the mac version of cindigo?


 Profile  
 
Offline
User avatar
Indigo 100
@fused:
Does Cindigo 2.2 Stable still work with the shortly released Indigo 2.4.3?
Or do we have to wait for an update?

If it works (partly?) what do we have to pay attention?

Kind regards,
Tom


 Profile  
 
Offline
User avatar
Indigo 100
Phoenix wrote:
@fused:
Does Cindigo 2.2 Stable still work with the shortly released Indigo 2.4.3?
Or do we have to wait for an update?

If it works (partly?) what do we have to pay attention?

Kind regards,
Tom

AFAIK there's no major changes nor any backward compatible problems

_________________
http://nunovasco.prtg.eu


 Profile  
 
Offline
User avatar
2nd Place Winner
2.4.3 works fine so far.
Some new features that "need" integration into Cindigo are:
Code:
- starting Indigo with network manager on export
- Adding wait_for_slave_frames_on_stop option to renderer_settings
- -thread_priority now changes whole process priority, so cindigo workaround isn't needed anymore
- control for verbose flag to control some output
- control for not caching kdtree to disk if less than N triangles

_________________
Cindigo user - My Portfolio
3 x 4770k with 32GB each


 Profile  
 
Offline
User avatar
2nd Place 100
Code:
- animation export for mac
- the ability to save both IGI and IGS into the same defined output folder

_________________
Cheers, David



ZENTAPHER // 3D.PORTFOLIO
·
Indigo 3.8.15 | Indigo for C4D 3.8.6 | C4D R14.042 | Mac OS X 10.10 | Windows 7 Professional x64


 Profile  
 
Offline
User avatar
Indigo 100
Okay, thanks for the disclosure! :wink:


 Profile  
 
Offline
User avatar
I think this is a bug?

A problem occurred with the scene:
SceneLoaderExcep: Error while parsing DiffuseTransmitter material: ComplexIORExcep: ComplexIORDataSetExcep: Failed to open file 'G:\Renderers\INDIGO v2\nkdata/nkdata/Au.nk' for reading. (In element 'phong', around line 106, column 9)
Indigo version: Indigo Renderer v2.4.3, Windows 32-bit Release

this is what I see in the saved scene file
removing one of the "nkdata" fixed it

<material>
<name>particles_mid3</name>
<phong>
<nk_data>nkdata/nkdata/Au.nk</nk_data>
<ior>1.400000</ior>
<diffuse_albedo>

although it might be a bug in the material itself. I downloaded it from the database. Or a Cindigo translation bug


also when importing these packed IGM files that have multiple entries of blends and what not, do I have to assign all the parts of the material to the object or just the base material item?


 Profile  
 
Offline
User avatar
Developer
CoolColJ wrote:
I think this is a bug?

A problem occurred with the scene:
SceneLoaderExcep: Error while parsing DiffuseTransmitter material: ComplexIORExcep: ComplexIORDataSetExcep: Failed to open file 'G:\Renderers\INDIGO v2\nkdata/nkdata/Au.nk' for reading. (In element 'phong', around line 106, column 9)
Indigo version: Indigo Renderer v2.4.3, Windows 32-bit Release

this is what I see in the saved scene file
removing one of the "nkdata" fixed it

<material>
<name>particles_mid3</name>
<phong>
<nk_data>nkdata/nkdata/Au.nk</nk_data>
<ior>1.400000</ior>
<diffuse_albedo>

although it might be a bug in the material itself. I downloaded it from the database. Or a Cindigo translation bug


yep, cindigo bug :)

CoolColJ wrote:


also when importing these packed IGM files that have multiple entries of blends and what not, do I have to assign all the parts of the material to the object or just the base material item?


just the root material. I really want to rewrite the indigo material in c4d (to make blending easier/to get rid of the mess of blend materials) but I dont really have the time for it :(


 Profile  
 
Offline
User avatar
Also Cindigo doesn't seem to be exporting the tone mapping settings.

There is no entry of it in the scene file, even though you can set it in the plugin


edit - might be a user error, since I rendered with the perspective view and not camera selected....


 Profile  
 
Offline
User avatar
Everytime I try to put this material on an object and export/render it, Cindigo crashes :(

http://www.indigorenderer.com/materials/materials/327

it makes heavy use of ISL and displacement etc
It even crashes if the material is not applied to an object


 Profile  
 
Offline
User avatar
Developer
CoolColJ wrote:
Also Cindigo doesn't seem to be exporting the tone mapping settings.

There is no entry of it in the scene file, even though you can set it in the plugin


edit - might be a user error, since I rendered with the perspective view and not camera selected....


yep, thats a user error :)


CoolColJ wrote:
Everytime I try to put this material on an object and export/render it, Cindigo crashes :(


ill look into it :)
thanks for reporting


 Profile  
 
Offline
User avatar
I discovered another issue

if I set the viewport to the editor camera and export the scene out to render Indigo complains about focus distance being at zero, even though autofocus is turned on

<focus_distance>0.000000</focus_distance>

when I switch back to the real scene camera and export, it's fine since there is a value there.


 Profile  
 
Offline
User avatar
Developer
CoolColJ wrote:
I discovered another issue

if I set the viewport to the editor camera and export the scene out to render Indigo complains about focus distance being at zero, even though autofocus is turned on

<focus_distance>0.000000</focus_distance>

when I switch back to the real scene camera and export, it's fine since there is a value there.


when autofocus is turned on, indigo determines the distance to the closest object, regardless of what is set in the xml.

does focus distance 0 give you an error? if not i'll just ignore it :lol: ^^


 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3  Next



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group